FreePBX Firewall Service not running after update

Good Morning:

I recently applied a firewall update and since then on my dashboard i see the red flame with the following msg " Firewall service not running! " .

I went ahead and applied yum update to see if I was missing some upgrade (Iptables) but no luck. The problem persist.

Any help would be appreciated.


fwconsole firewall start

I just tried it and the problem persist.


Did it broadcast a message “Firewall Service Starting Now” ?
Did you refresh your dashboard?

It did not broadcast any msg, and yes i refresh the dashboard. I even logged off and on.


OK, and when you go under Connectivity > Firewall, can you start it there?

When i go to Connectivity/firewall/Status I get this:
Firewall is not running!

What i would do:

fwconsole firewall stop
fwconsole ma delete firewall
fwconsole reload
fwconsole ma downloadinstall firewall
fwconsole reload
fwconsole firewall start


I followed your advice and the problem persist. I still see the red x on my dashboard.


Which version of FreePBX are you using?

Good Morning:



Hi, Josep20.

Had the same issue this morning with a bunch of servers. Here’s what worked for me:

  • fwconsole chown
  • fwconsole firewall start

Some still wouldn’t start so ran:

  • fwconsole ma refreshsignatures
  • fwconsole firewall start

Hope this helps.


hello, thanks for your input. Sadly I just tried those commands and still have the red X on my dashboard with “Firewall Service not running”.


Can someone else recommend something else? I still have this issue.


Did you try to reboot your server?

Or perhaps do you have any pending updates?
fwconsole ma upgradeall
fwconsole reload
fwconsole firewall start

Thanks @PitzKey , did the steps you suggested, but no luck.


Can you post the full error you get when running fwconsole firewall start?

Not sure if there’s any update available, but i’d also try to upgrade to edge

fwconsole ma --egde upgrade firewall
fwconsole reload

Hello, it did not work.

This doesn’t appear to be the freepbx official distro.

good morning; @tm1000 It is a freepbx official distro, we bought the appliance from sangoma.