FreePBX Distro hangs at install

I recently upgraded my computer with a new motherboard, memory, CPU, and SSD. I’m trying to install FreePBX distro 10.13.66-64bit on the computer. The install hangs every time at the same spot, the last line on the screen says

[<ffffffff8100c200>] ? child_rip+0x0/0x20

I’ve tried installing the PBX 13 no RAID option (which I want, I have a warm spare) and the PBX 13 advanced option. Both hang in the same spot. I have successfully installed Ubuntu Server 16.04.3 LTS as a test as well as Windows 8.1. While I had Windows installed I installed drivers from the Motherboard disc.

The computer is connected to the internet and I did a successful ping test while in Ubuntu Server.

Computer hardware specs:
Intel Core i3-7100 Kaby Lake Dual-Core 3.9 GHz LGA 1151
Team Elite Plus 4GB 288-Pin DDR4 SDRAM DDR4 2133
ASUS H110M-E/M.2 LGA 1151 Intel H110 HDMI SATA 6Gb/s USB 3.1 Micro ATX Motherboards
WD Blue 250GB Internal SSD Solid State Drive - SATA 6Gb/s 2.5 Inch

Any idea how to get around this?

I was able to chase my problem to the motherboard. Is it possible the motherboard isn’t compatible with Centos/FreePBX? Or am I missing a driver?

Try installing the 14 Distro, it’s the current version anyway.

This is my warm spare server I’m working on. My production server runs FreePBX 13. So, I’m assuming, I need to install FreePBX 13 on the warm spare as well, right?


It also stalls for a minute at

Refined TSC clocksource calibration 3911 MHz.
switching to clocksource TSC

So, possibly a CPU issue?

Have you tried installing the latest CentOS 7 as a test?

I just tried installing a fresh copy of Centos 7. It acts like it’s installing, then it hangs at a black screen with a cursor. It has been hanging there for about 20 minutes now.

Try pinging the CentOS community to see if this issue is known. How new is the processor? Year and month of release?

I’m not sure when the release date was on the CPU, this is the one I was using.

I did try a Core i7 I had laying around. I had the same results with the i7 in the motherboard. It seems to be a motherboard issue. I’ve returned the motherboard and am going to try again with this one.

This is just purely personal preference but I’ve always had great luck with ASUS boards. Still have some P4 boards I keep around in my lab for testing.

I got a new motherboard in today (GIGABYTE GA-H110M-S2H LGA1151 Intel H110 Micro ATX DDR4 Motherboard) and it hangs at the same spot.

I’m heading over to the Centos boards to see if I can find a solution.

So, I think I solved this. It appears to be the CPU. It looks like Centos 6.6 doesn’t support any intel CPUs over 4th gen (Haswell). I was able to install FreePBX 14 on the computer, but that doesn’t work for me since my production server is on FreePBX 13 and I haven’t been able to get it to upgrade to 14. (Trouble using Sangoma 6 to 7 upgrade tool)

I’m reverting back to the old hardware until I can get my production server upgraded to FreePBX 14.

Lack of support for modern processors in CentOS 6.6 is a major stumbling block now if you’re trying to install v13 on newer hardware.

It was something I wasn’t aware of when I first encountered it a year or so ago.