Freepbx dashboard broken several power outages


I noticed that the “dashboard” function isn’t working anymore. I mean the dashboard will load the first time. When I press refresh on the browser or by pressing again on the “dashboard”, the panels will not load.

So I SSH into the FREEPBX server and run fwconsole reload. I get the following error.
PHP Fatal error: Class ‘modgettext’ not found in /var/www/html/admin/modules/faxpro/ on line 0
Whoops\Exception\ErrorException: Class ‘modgettext’ not found in file /var/www/html/admin/modules/faxpro/ on line 0
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/modules/faxpro/

Please show me how to fix this error.

I just find out that the system admin module is broken. I tried to reinstall it using FWconsole but it doesn’t work. On the GUI it shows it is broken and that’s a dependency for other modules? What should I do?

maybe try to disable the fax pro or reinstall it by fwconsole.

I tried. Every time I type fwconsole, I get that error message.

you get the same error when typing fwconsole ma disable faxpro ?

After disorderly shutdown, the MySQL databases may be corrupt:

mysqlcheck --repair --all-databases

If you are not a faxpro user, and you can’t remove with fwconsole, you can delete with:

rm -rf /var/www/html/admin/modules/faxpro/

It seems the problem is worse. I can’t even issue simple Linux command like “reboot” or “shutdown now” from the terminal. As a result, the only remaining solution was to simply reinstall Freepbx 14 then restore from backup.

It solved the issue.

A UPS protects against power line “events”, the kind that smoke PSUs, and apcupsd will shut the pbx down in an orderly way to protect the filesystem if and when the backup battery runs out of juice. Pretty basic precautions and not expensive to implement.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.