Freepbx as Voicemail provider with cucm, MWI issue

Hello Guys,
I have installed freepbx, and integrated with Cisco cucm in my network here.
I intended to used the freepbx as voicemail system and t worked fine BUT:
Only one single problem which is MWI “message waiting indicator” still not working and I have been through many links about this point and all didn’t work.
I am very confused what is the missing block between the tow system.
when a call from DN1 “Cisco side” to DN2 “Cisco side” takes place, and when the DN2 not answering the call for any reason, it successfully transferred to the voice mail “freebpx” to record the voicemail successfully but the Cisco phone side doesn’t get the flashing indicator MWI.
“The scenario is simply when DN1 call DN2 and after a specific num of rings with no answer, or the DN2 is not alive, the call automatically forwarded to a similar DN on the freePBX system with same DN but virtual DN which is not active so a recording message now takes place successfully, but the DN2 on Cisco system is not getting any MWI”. and finally, am not a developer :frowning:

I saw you said that you’ve been looking things up. Did you see this one?

I imagine this is more a more niche issue (limited knowledge by the larger group). Perhaps reaching out to the poster of the thread above might provide some additional clues. The voicemail system isn’t actually FreePBX. It is the Asterisk voicemail application. Given that, the Asterisk forum might be a good place to find someone who could be able to help as well.

https://community.asterisk.org/

1 Like

Yes, An I have been through this document and still not working in my scenario.
I even from time to another try to read and apply it again may be I do something wrong and it may succeed once, but still not working so far.
TIA

I would talk to @Coopercentral to see if he could help.

Hello,

It’s been awhile since I visited this, but yes I still have my setup working. I have a a SIP trunk on FreePBX to my SIP provider, and another SIP trunk to my CUCM server. Is your trunk setup correctly between FreePBX and CUCM? In CUCM, did you setup extensions dedicated for MWI (Advanced Features -> Voicemail -> Message Waiting)? From your Cisco phone, can you dial the MWI extensions and have the light turn on/off?

I used the same script as per this post:

Where they reference “@callman”, I changed “callman” to be the name of my SIP trunk between FreePBX and CUCM. I also changed the extensions obviously for my MWI. This script is called “vm.sh” and in /var/lib/asterisk/scripts.

Then, edit /etc/asterisk/voicemail.conf, and under “[general]” I have…
externnotify=/var/lib/asterisk/scripts/vm.sh

I hope that helps.

Hi Cooper,
Regarding your first part, about the sip trunk between the asterisk and cucm, and calls from and too both sides working fine.
extensions as mwi on/off are created and yes I can call these extensions which turn light on/off.
My problem is with the second part “The script”, I have created the script and made the changes to externotify but still not luck.
but since my try was about 3 months ago, I will try the script part again and see what will happen and reply to you.
TIA Cooper.

Hello Cooper,
The mwi still not working I wounder where is the problem but I think it’s something in the setup.
I will give you a brief of my setup:
My call manager dialing extensions are 2XXX, all my extensions created on cucm and ok.
for every cucm extension I intend to have a voicemail box, I create a custum sip extension on the freepbx with the same extension, ie, 2065 on cucm and same 2065 on the freepbx too with voicemail enabled.
every extension on cucm can successfully check it’s mail box on the freepbx.
the script contents are as follow :
#!/bin/bash

CONTEXT=$1
EXTEN=$2
NUMVMS=$3

Turnoff=“Channel: SIP/[email protected]_CUCM-sub1\nCallerid: $EXTEN\nMaxRetries: 0\nRetryTime: 5\nWaitTime: 5\nContext: $CONTEXT\nExtension: $EXTEN”

Turnon=“Channel: SIP/[email protected]_CUCM-sub1\nCallerid: $EXTEN\nMaxRetries: 0\nRetryTime: 5\nWaitTime: 5\nContext: $CONTEXT\nExtension: $EXTEN”

if [[ $NUMVMS = “0” ]]; then
echo -e $Turnoff >> /var/spool/asterisk/outgoing/$date.call
else
echo -e $Turnon >> /var/spool/asterisk/outgoing/$date.call

fi

knowing that To_CUCM-sub1 is the reunk name on the freepbx that connect to cucm.
2998 and 2997 are mwi on/off

from this and when we think, we find somehting missing because cucm can reach freepbx extensions using route pattern *2XXX, but when it’s the notification mwi from freepbx to cucm it will then notify “i think” the internal custom sip extension" how to make sure that my script mwi generated are sent to cucm actually?

any ideas plz, TIA

I wanna add something …
if i run the script from the cli it gives the output…
[[email protected] ~]# bash /var/lib/asterisk/scripts/vm.sh
/var/lib/asterisk/scripts/vm.sh: line 5: SIP/[email protected]_CUCM-sub1nCallerid:: No such file or directory
/var/lib/asterisk/scripts/vm.sh: line 6: SIP/[email protected]_CUCM-sub1nCallerid:: No such file or directory
[[email protected] ~]#

if I call these mwi extension on from the freepbx it give “all our circuits are busy now” then hang up.
Do I need to create the mwi extensions mentioned before 2997 and 2998 on the freepbx too? what does this output mean?

in the same time if i enable the logs for asterisk -r , and when I excute the script above manually it logs :
[2018-05-28 10:59:20] WARNING[1896]: pbx_spool.c:298 apply_outgoing: At least one of app or extension must be specified, along with tech and dest in file /var/spool/asterisk/outgoing/.call
[2018-05-28 10:59:20] WARNING[1896]: pbx_spool.c:480 scan_service: Invalid file contents in /var/spool/asterisk/outgoing/.call, deleting
localhost*CLI>

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.