FreePBX and PHP 5.6.19


(Alep) #1

Hi all,
I’m a NethServer developer and I’m trying to install FreePBX 14 on CentOS 7.

I would like to know why fpbx 14 requires php version 5.6.19 with this specific minor version instead of simply 5.6.

Default php version on CentOS 7 is 5.4, but with scl I can use php 5.6.5.
When I install freepbx this line cause installation exit:

So I must patch it to relax the php version.

Thanks.


(Andrew Nagy) #2

We require 5.6.19 because of specific module requirements and database requirements. You should not be changing that to suit your needs. There are other rpm libraries out there with php 5.6.24. Like webtatic. Please use that.

Every time we release an update for framework it will be blocked on your install until you get a higher version of php


(Alep) #3

I must to be strictly stay with the upstream version, so at least I can use scl version 5.6.5.
From github I’ve seen that freepbx php version has skipped from 5.3.3 to 5.6.19: so, have you used some functions of 5.6.19 that are not present in 5.3.3 ?

What is the main goal of that version increment ?


(Andrew Nagy) #4

As previously stated

Yes. Our entire Composer base. FreePBX 14 is based off of our Sangoma 7 distro which is using php 5.6.24 right now. I suspect by time of release we might put the version requirement to 5.6.24. However 5.3.3 is not going to happen. You can check our Composer requirements here: https://github.com/FreePBX/framework/blob/release/14.0/amp_conf/htdocs/admin/libraries/Composer/composer.json

For example one of our module requirements needs PHP 5.6 ( https://github.com/OzzyCzech/icalparser )

If you want PHP 5.3.3 support I advise you use FreePBX 13. In fact I am not sure why you choose FreePBX 14 as that’s not even in beta. It’s alpha.

Do you want support for PHP 5.3.3 or PHP 5.6.5?


(Andrew Nagy) #5

I was just alerted to your repository where you are doing patches to FreePBX against patch files.

Can you please submit these patches as Pull Requests to FreePBX? Doing patch files like this are just going to break FreePBX as we move along in development for 14 so why not get them in instead of hosting them in a separate repository?


(Alep) #6

Thanks to @edospadoni here is the pull request for our patches:

We only need a php require of 5.6 because we can use scl version 5.6.5.
In this way we can stay upstream with your project :wink:


(Andrew Nagy) #7

Thanks.

I’ve been reading this thread http://community.nethserver.org/t/asterisk-13-and-freepbx-14-on-nethserver-7/4003/18
and I have some serious concerns about the Nethserver project. Specifically I see people installing FreePBX 14 on php 5.4. All of the coming calendar functions will break on php 5.4. There is no work around. Furthermore the Symfony project (which we use for fwconsole commands) is 5.5 only.

I strongly urge you to use php 5.6. In the coming week we will be adding more checks to FreePBX to ensure it really is running on PHP 5.6.

Is there a reason you are letting people install FreePBX 14 on php 5.4?


(Alep) #8

@tm1000 thanks for your interest and participation :slight_smile:

I’ve been reading this thread http://community.nethserver.org/t/asterisk-13-and-freepbx-14-on-nethserver-7/4003/185
and I have some serious concerns about the Nethserver project. Specifically I see people installing FreePBX 14 on php 5.4.

This is not really correct. As explained above, we execute FreePBX 14 with php 5.6 using scl version. So, the system uses php 5.4 to remain upstream with CentOS, but php 5.6.5 is used only with fpbx in a confined environment.

In the coming week we will be adding more checks to FreePBX to ensure it really is running on PHP 5.6.

Great, if so and freepbx requires only 5.6 version as requested by the @edospadoni PR, we will stay upstream with you and we should have no problems :thumbsup:


(Alep) #9

Hi @tm1000, any news about @edospadoni PR ?
Is it possible to requires php 5.6 ?