We require 5.6.19 because of specific module requirements and database requirements. You should not be changing that to suit your needs. There are other rpm libraries out there with php 5.6.24. Like webtatic. Please use that.
Every time we release an update for framework it will be blocked on your install until you get a higher version of php
I must to be strictly stay with the upstream version, so at least I can use scl version 5.6.5.
From github I’ve seen that freepbx php version has skipped from 5.3.3 to 5.6.19: so, have you used some functions of 5.6.19 that are not present in 5.3.3 ?
I was just alerted to your repository where you are doing patches to FreePBX against patch files.
Can you please submit these patches as Pull Requests to FreePBX? Doing patch files like this are just going to break FreePBX as we move along in development for 14 so why not get them in instead of hosting them in a separate repository?
This is not really correct. As explained above, we execute FreePBX 14 with php 5.6 using scl version. So, the system uses php 5.4 to remain upstream with CentOS, but php 5.6.5 is used only with fpbx in a confined environment.
In the coming week we will be adding more checks to FreePBX to ensure it really is running on PHP 5.6.
Great, if so and freepbx requires only 5.6 version as requested by the @edospadoni PR, we will stay upstream with you and we should have no problems