FreePBX and Dahdi configuration

Hi All,

I have recently installed Asterisk 1.4.23, Dahdi and FreePBX

everything is running fine… I need to know about configuring a Digium board TE410P…Do I just modify /etc/dahdi/system.conf and /etc/asterisk/chan_dahdi.conf to specify all the parameters?

I googled it and I came across a thread that said I have to use FreePBX and do not modify chan_dahdi.conf, just add
#include dahdi-channels.conf
#include chan_dahdi_additional.conf

to chand_dahdi.conf and use FreePBX to do the rest…

my question is, where do I specify the groups… for example I wanna add something like:

group = 1
switchtype = national
signalling = pri_net
context=from-trunk
channel => 1-23

how do I do that in FreePBX?

Thanks for your help

Did you run the config generator for Dahdi channels dahdi_genconf?

I find that most of the time that tool generates the required configuration without me having to touch system.conf or dahdi_channels.conf

Anyway, I don’t think FreePBX touches /etc/dahdi files or chan_dahdi.conf or dahdi-channels.conf so you should be able to modify them as you want. There might be a problem with the FOP if you don’t have a proper dahdi-channels.conf file though…

For compatibility sake you might want to have chan_dahdi.conf filled with general parameters and also including dahdi-channels.conf, the file that creates the channels, some of my files look like this:

chan_dahdi.conf:

[trunkgroups]

[channels]
context=from-pstn
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
faxdetect=incoming
echotraining=800
rxgain=0.0
txgain=0.0
callgroup=1
pickupgroup=1

;Uncomment these lines if you have problems with the disconection of your analog lines
busydetect=yes
busycount=3
hanguponpolarityswitch=yes

immediate=no

#include chan_dahdi_additional.conf
#include dahdi-channels.conf


dahdi-channels.conf:

; Autogenerated by /usr/sbin/dahdi_genconf on Sat Aug 29 10:25:12 2009
; If you edit this file and execute /usr/sbin/dahdi_genconf again,
; your manual changes will be LOST.
; Dahdi Channels Configurations (chan_dahdi.conf)
;
; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
;

; Span 1: WCT1/0 “Wildcard TE122 Card 0” (MASTER) HDB3/CCS/CRC4 ClockSource
group=0,11,12,13
context=from-zaptel
switchtype = euroisdn
signalling = pri_cpe
pridialplan = local
internationalprefix = 00
nationalprefix = 0
channel => 1-15,17-31
context = default
group = 63

thanks…

in your chan_dahdi.conf, it says signalling=fxs_ks what do I do in my case? for example I want the signalling on quad port to be pri_net and pri_cpe

do I just remove signalling=fxs_ks and just specify it in dahdi-channels.conf?

thanks again

It’s not a problem, the signalling type used in the channel will be the last one defined before the “channel =>” statement, so you could just remove the first “signalling=fks_ks” on chan_dahdi.conf and only use the ones on dahdi-channels.conf

I am using T1/PRI asterisk 1.4. I have setup DID’s for 15 users which is working fine for incoming calls. But when they call out, some of them got call terminated. In asterisk CLI, I notice messages saying “Dahdi 1/1 circuit busy”. How can I set up channels correctly so that they can use any channel that is free but display main number as caller id? I will appreciate for help.

Thanks!