FreePBX adaptive firewall


(Fx Llama) #1

In FreePBX 13 and now on FreePBX 14 I am having a problem where the adaptive firewall is not picking up authenticated users nor is it blocking users with incorrect passwords etc. I have had 3 FreePBX installations all on different hardware setups but none of them work. I have double and triple checked my firewall setups even following the FreePBX official video on YouTube. Now the only thing that is common with these 3 installs was that I changed the Chan_Sip port from default 5160 to 15060. Would the firewall bypass checking this port because it is no expecting a port of 15060? If this is the case is there a config file I can edit to change what port the firewall expects Chan-Sip to be on?


#2

It should allow whatever port you’ve bound the service to. Have you enabled the responsive firewall for CHAN_SIP in Connectivity>Firewall>Responsive Firewall>Legacy SIP (chan_sip)>Enabled?

You also need to make sure you haven’t touched the services settings to allow CHAN_SIP to be open to the internet. If you set this service to the internet zone, the responsive firewall won’t work.

Let me know how you get on…


(system) closed #3

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.