FreePBX 16 New Install Can't Activate

I have installed FreePBX many times and have not ran into this. I installed the latest version of FreePBX 16 and installed all of the updates. But can’t activate it. I reinstalled and tried again. Still I get the below error:

Activation Error!

Unable to display activation page. Error returned was:

Operation timed out after 30001 milliseconds with 0 out of -1 bytes received

This is likely an internet/network/DNS issue.

How to set Network Settings from the CLI - PBX Platforms - Documentation (

Getting the same error, been trying to fix it for an hour.

PJM…I would give up…something is broken

I have done a lot of these, been working working with FreePBX since the early days “asterisk@home”, and have done a lot of recent installs FreePBX 13, 14, 15, 16, and I have many other installs that are setup the same way, but the one I did today will not activate (and my networking is correct)…and still I went through the page that Comtech provided (old hat can still learn new tricks)…but no luck

Getting the following error

Activation Error!
Unable to display activation page. Error returned was:
Operation timed out after 30000 milliseconds with 0 out of -1 bytes received

nothing to do with DNS, as performed a yum update and also performed a module update with no issues, removing the network and dns issues, and we are not behind a proxy or other firewall.

If I perform it at the command line (have obfuscated the email we use for registration). As you can see it appears to be validating our email (so it is in the first phase of the transaction), so again confirming no network connectivity issues.

[root@freepbx ~]# fwconsole sa a [email protected]
Attempting to activate against email address ‘[email protected]
Running /var/www/html/admin/modules/sysadmin/bin/register_new [email protected]
Validating email…OK!
Asking for deployment ID…Pest_Curl_Exec: Operation timed out after 30000 milliseconds with 0 out of -1 bytes received in file /var/www/html/admin/libraries/pest/Pest.php on line 232
Stack trace:

  1. Pest_Curl_Exec->() /var/www/html/admin/libraries/pest/Pest.php:232
  2. Pest->doRequest() /var/www/html/admin/libraries/pest/Pest.php:364
  3. Pest->post() /var/www/html/admin/modules/sysadmin/Reg.class.php:66
  4. FreePBX\modules\Sysadmin\Reg->kPost() /var/www/html/admin/modules/sysadmin/Reg.class.php:177
  5. FreePBX\modules\Sysadmin\Reg->getDeploymentID() /var/www/html/admin/modules/sysadmin/bin/register_new:43
    [root@freepbx ~]#

So I think we will need to wait for Sangoma to resolve the activation issue.


1 Like

I’m joining you. A similar problem!

We have some issues in the backend services due to which activation is not working right now.
Please check the below status page -

Best Regards,

1 Like

license server down…

1 Like

HI Kapil

Do we have an ETA on a fix for licensing as we and im sure many other are stuck with servers unable to add new licences



I"m still unable to activate a new deployment. Is this expected to be fixed soon?

1 Like

Having the same issue


I have the same issue

Same issue on purchasing sangoma connect licenses

Same issue with purchasing FreePBX call recording report.


Thanks for your reply here and also on the bug report that was submitted.

Also thanks for the link to Sangoma Status, which I have added to our documentation and will be first point of call in future.

Just for anyone reading, at the time of this message, system is still down and not responding…and the Status page is showing this as well.


Quick update, there’s work scheduled overnight tonight that is expected to get the problem DB system back up and running again. Barring any unforeseen developments, FreePBX/PBXact licensing services should be up and running tomorrow morning North America time. If that’s not the case, I’ll try to update this thread with details at that time.

Edit: Things should be back to normal now.


Thanks for the update Lorne,


Wow, system registration is back to online.

Requesting all of you to please give a try again and let us know if you face any issue in activation or in licensing.

Best Regards

Thanks for the update

Whilst I have not gone through the whole process of activation, I am now getting the expected response whilst starting activation, and no longer timing out, so appears to be working.

will perform proper test in 12 hours…



I am new user, now after fill the registration form and press the Create button nothing happens.