FreePBX 15 Not shutting down

Anyone know why the Distro version of FreePBX doesn’t shutdown properly?

Hi @tonnic
What do you mean ? If you type “poweroff” or “halt” on your CLI it doesn’t shutdown ?

Yes the machine doesn’t actually turn off. The console looks like it is shutting down and disconnects me but the system stays on. I can’t ssh into it, but the state doesn’t actually turn off.

This is challenging because it never turns off to reboot itself.

This happens on my own proxmox installation as well as a a vps that I purchased from a hosting provider. Both are distro installations.

Does reboot work for rebooting?

Nope. It hangs too.

Probably an ACPI kernel driver issue. Is it a physical server or a VM ?

VM. Anyway to fix this?

Seems like the host environments are causing some trouble. If you are willing to experiment, it looks like this answer could work.

Agreed with the acpi(d) bits, what is the actual hardware on which this is all being done? does it have a bios? does that bios have any ‘likely suspects’ ?

Have the same problem on my hardware. Any Windows installation will shutdown and restart normally but FreePBX 15 won’t. This Thread might have some ideas for you.

Nope that didn’t work… I love proxmox, as I tried that on my home lab and it didn’t work so I reverted a backup that I did right before. Don’t have that option with my rented provider though.

I’ve had this kind of stuff a some years ago, and adding this option somewhere in boot option that worked.


I have that issue on Sangoma branded PBXact box and couldn’t get any traction on it. I’m sure its something like ACPI, but jeez spending a Saturday to work out the bugs in a system isn’t ideal right now.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.