Shutdown and Reboot Just 'Hang' & Had to Manually Configure Network (ifcfg-eth0)


(John Jarrett) #1

I have installed FreePBX Distro, 15.0.16.50, on a Celeron Micro ITX fanless UEFI motherboard of an unknown origin/make. (eBay). Nice little box BTW. But a couple oddities occurred that someone may have some knowledge of.

1). After installation I logged into the CLI locally and no IP was shown after login but a MAC was shown. After looking at ifcfg-eth0 one line had some non fatal error message written. I wish I would have copied the text. A lot of stuff didn’t make sense and a lot of IPV6 lines which I am not using on my network. DHCP was enabled. Anyway, after configuring the file properly and my dns conf file, things worked fine. I was able to login to the web GUI and Restore a V15 backup from another system.

2). I realize that there may be little that FreePBX and it’s underlying Linux core may find compatible with this unknown make, brand, micro ITX Celeron system but if I use System Admin to Shutdown or Reboot, OR the CLI using ‘reboot’, ‘shutdown’ etc., the system appears to Halt with “Rebooting” or “Shuting Down” on the CLI session. Just sits there… forever. I can hold the power button and it will then turn off and I can restart it and the filesystem always comes up clean.

Is there something I should look for in the BIOS that might help this system reboot or fully shutdown? The BIOS only has a hibernate or sleep setting which is disabled.

Thanks for any thoughts or insight!

John


FreePBX 15 Not shutting down
#2

Just guessing here:

I’ve run FreePBX on machines like

They won’t boot up without a monitor connected, so I use something like

Possibly, you found a UEFI setting that avoids the boot-up issue but the lack of a monitor is still causing trouble on shutdown.

See whether connecting a monitor helps. If not, the monitor may show what is going wrong in the shutdown sequence.

Otherwise, does anything get logged that relates to the shutdown failure?


(John Jarrett) #3

Thanks for the thoughts! The monitor is connected. Ahhh… logs! I forget that Linux is built on logs! Any idea which log(s) might show shutdown. I’ll Google it but any other thoughts most appreciated!! Thank-you!

John


#4

Start with /var/log/messages but anything written after you gave the shutdown command might be useful.


(John Jarrett) #5

That’s where I went, then boot log and then just rummaged around the logs. According to the logs, the system always fully halts but will not turn off or reboot. No errors are ever logged. Am I missing a setting in the BIOS?

Any thoughts appreciated!

Thanks!


#6

You probably need to experiment with the acpi related parameters on the bootloader.


#7

Likely a hardware thing, I would also go straight to acpi if you have it

https://www.kernel.org/doc/html/latest/power/apm-acpi.html


(John Jarrett) #8

Well, I tried and somehow this little thing, I think, was designed to not shutdown unless it is unplugged. Some kind of surplus appliance type unit. I’ve checked everything and no joy and very limited config, only a sleep parameter in the bios for a non existant sleep switch. But, this is how I learn. Good time to learn and relearn stuff.

Have another unique problem which I’ll post in a bit.

Thanks guys!

John


(system) closed #9

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.