FreePBX 13.0.192.19, H264, video calling

Good evening,
I am running FreePBX 13.0.192.19 distro.

I have a Grandstream GXV 3275 which uses h264 for video calls.

I tried doing searches on how to enable the H264.

One said all that had to be done was to enable the codec in the setup. Well, H264 is not an option to actually enable.

so with that, I think, ok, H264 codec must be installed, so I looked for a module. Cant seem to find one.

Can anyone point me in a direction of adding the H264 and setting up video calls so that I dont go off on my own and screw up the FPBX box?

Thanks in advance
Tom

ok, Thanks, now I realize that my video capable phones are useless as far as video goes.

Regards
Tom

And why is that? Have you not enabled the codec on FreePBX? Also, there’s no video support over the PSTN so the video calls would only work extension to extension.

Your phones are perfectly capable of video calling with FreePBX.

In order to enable video in Asterisk, add the following variable to your SIP configuration, under the general section:

[general]



videosupport=yes

Then for each SIP user / peer, you have to add the supported codecs. Depending on your Asterisk version, you might want to avoid video codec negociation, so make sure that you enable a single video codec. Also, reinvite=no might be needed, if you have reinvite=yes and the video is not coming up, try setting it to no.

Thanks for info. but as stated above, enabling the codec is not an option. Cant be found.

Thats ok, I am to ugly to be on video anyway!! :wink:

Have a great Christmas.
Tom

Thanks for taking time to reply. I gave up on video. No major need for it anyway. Maybe later it will be better implemented and more widely used.

Thanks
Tom

You should be able to see video codecs when you enable Video Support, otherwise they will not be shown. If you are using CHAN_SIP, then you need to go to “Settings” -> “Asterisk SIP Settings” -> “Chan SIP Settings”, then set “Video Support” to “Enabled” and you will be presented with a list of available video codecs. If you are not using CHAN_SIP but CHAN_PJSIP, you should perform a similar process, but I’m not sure about it as I don’t use CHAN_PJSIP.

That must be my problem. I am using CHAN_PJSIP.

I cant find any properties about video calls with that. so. Ill just write it off for now.

Thanks again, for all the thought you put into it.
Regards
Tom