Free pbx and compatible cisco phones

FreePBX info-

Firmware- 1.1010.210.62-3
Service Pk-

Can someone confirm/recommend a cisco phone that works well (including easy setup) with freepbx?

I have the Endpoint Manager installed and I see the following phones can be managed from the GUI of freepbx

Cisco 7940g, 7941g, 7961g

Cisco 7940, 7960

I assume any of those phone will work, but I have a 7970g that gave me a lot of issues (still not working. A member on this forum sent me a PM and logged into my system and tried everything he knew to try and we still couldn’t get it to work.

I would like to get a phone that is PoE ready (that doesn’t require a cisco PoE switch).



Note: These Cisco IP phones support both the Cisco pre-standard PoE and IEEE 802.3af PoE:

7961G <-----
7941G <-----

Those are my only two options for PoE

I would appreciate a posting of the 7942g file. I have had, to say the least, no luck in getting these things to work with my FreePBX setup. I, however, have determined they will look great as edging around the flower bed in front of the office.

Have yet to use a “big boy” Cisco phone on an install. Typically use the Small Business products like the SPA504G or SPA509G. Both of those models work great with standard 802.3af PoE, as well as some of the other phones in the 500 series. Can be configured via web config or XML / endpoint provisioning.

Did you purchase the 7970g brand new? I believe it has to have the SIP firmware loaded on it to work correctly with Asterisk/FreePBX etc.


i want to use the ‘big boy’ phones

these are 802.3af compatible (that i would like to use).


for the 7970 issue, i have another thread dedicated to that phone. a member from this forum sent me a PM and tried a few XML files and we still couldnt get to work.


i have a 7961 sitting next to me and it works fine.

We use 7961, 7941 & 7911 all work fine.

@dpilon and fn-gm

Thanks for the confirmation. Anything special you did to get them working?


I didn’t use Endpoint Manager, just standard TFTP and xml config files.

I’ve just setup a bunch of SPA502G’s and SPA504G’s for FreePBX.
All been “adjusted to suit local conditions”, and seem to be working nicely.
Eg softkeys displaying features we need on first screen, so no unnecessary scroll to second screen during calls.
PoE without using any proprietary protocols.
All good. HTH.

I originally set mine with to use chan-sccp-b, but now I use sip…I have set them up with epm and also just tftp and xml config files edited by hand.

@ dpilon

Good to know, thanks. I think I will try the EPM. I have already configured it to use a 7961g and filled out everything I could, without having a phone.

I just need to decide if I want to buy a phone to see if I can get it to work.

If more than 1 person in this thread has already commented saying that it will work, that should be a good sign.

I have a 7961g phone and I have all of the SIP firmware files in the TFTPboot directory.

I did a factory reset on the phone and It loaded up to the firmware update page. It shows my MAC address and updating progress. It sits there for a few minutes, quickly flashes term61.default.loads (two times, I believe) and then begins a reboot cycle. I thought that might be normal, so I let it go, then it repeated the process. I have not shut the phone off since the firmware upgrade.

These are all the files in the TFTPboot directory:


XMLDefault, termxx.loads or the phone mac.cnf file must refer to the wrong version of software.

It’s case sensitive.

Must be something with the term.loads files, since those are the only ones in the TFTPboot directory. I didn’t change any case, everything was left as is from the .zip.

There should be no need to modify the terms files…they are provided by the package.

Sometimes you may have to find an old firmware to start with then update gradually to newer versions. I know that is how I got mine to finally upgrade to a newer version (I now use the SIP 9.3 firmware). Without these older version…after a factory reset the phone would just try to loop the terms file a couple of time. (you can confirm this in your tftp log) Looking at my files…it looks like i had to start at 8.2.2 then upgrade to 8.3, then 8.5.2…then the jump to 9.x was possible.

I just tried uploading 8.2.2 and it quickly ‘looked’ like it said error on the phone…on the second loop of the same process now. I just don’t get it.

Interesting, it seems to like/have taken this one…


Now sitting at the main screen, unprovisioned. I haven’t messed with any of the config files, yet. Will do that tomorrow.

Whatever you do don’t go to version 9, it has interop issues with Asterisk and requires patches.

To my understanding the EPM does not support the newer Cisco CUCM phones as they use XML config files. Even though it says it does I think you will find it writes a 7940/60 flat file type config.

And once you make your SEP(MAC) config file make sure the software version matches XMLdefault or the phone will enter a race condition between the two versions.

These phones are not for the timid! I have bricked many before I got good at it. I have done at least 1000 in the last two years, if you write the configs write you can bounce the PoE on the switch and they will all auto update. We then take the call manager out back and shoot it.

Ok, finally making progress. Ended up using the Endpoint Manager in FreePBX. The phone still says registering (from unprovisioned) and I see my name and 1000 (extension) in the upper left of the phone.

I get dial tone (assuming this is fake dial tone all PBX systems throw out). I must be missing something if it won’t register, but it does appear that something is happening.

Not sure what I am missing, I thought I went through all the options in the Endpoint Manager that asks me specific stuff about the phone/line.

Do I need to fill anything out under the phone template page for it to finish registering?

Services URL:
Directory URL:
Logo URL:
Firmware Image Name:
Preferred Audio Codec:
Date Format:

Those are all blank.