FPBX now applies all outgoing CID to 1-999-999-9999

It just started about one week ago and I have not made any changes. There was a MOH update, but …I don’t see this affecting CID.
Every single call is being sent as 1-999-999-9999, even the ones from extension to extension.

Any ideas?



checked your CLI, it is almost certainly related to your carrier and you can see in the CLI what FreePBX is trying to send.

I see what you mean, but as mentioned an internal extension to extension call is also being sent as ** “Name Unavailabl” <9999999999> **

That being an internal call, cannot have anything to do with any carrier, but me…since I would be the carrier.

I take it back…I see what is going on, studying the logs in detail.

You are correct. I need to contact the carrier.

Thanks a lot.


feel free to check out https://store.freepbx.com we if you are in the US, you can set you CID with our service and you won’t have this problem:-)

I turned on SIP debug and I don’t see my system sending out CID at all even though I have it on the extension and trunk. Though further testing shows the CID being sent out to other extensions, local extensions that is.

Looks like I will have to put it in the Peer Details of the trunk? Though the problem is some extensions have their own direct number.

running off to catch a plane so no time to comment further other than to say that FreePBX sets the CID if you configure it properly, no need to set it in the sip settings.

See if someone else can help you further…

What is “properly?”

I have been using FPBX for over a year and have not had this problem before.

Anyone, anyone?

I called myself so I can see what is going on out and coming in.


Thanks again!

Hmmm, you say that you call yourself, and I can see that when the call is received it has been set to 9999999999 but the outgoing CID is OK.

Is there a way for you to just call out to like your mobile phone so that we see that the outgoing call is OK? Then call in from a mobile phone to your pbx so that we see what you receive?

Call from asterisk to mobile, what CID do you see in mobile?
Call from mobile to asterisk, what do you receive?

All with set verbose 5 and agi debug

I only called myself so that is going on can be seen completely,. The incoming CID is not the problem. It is what is going out the trunk that is. I called my cell phone and on this particular service provider I am getting no CID on the cellular…

Some people are reporting they are getting a local number for their area.

Maybe it is my provider after all?

Yes, I suspected that after seeing that strange log. Call your provider and ask them about it.

Thanks, and I will post their response here

Come on, nobody can take a guess? I should take a look through he sip.conf files and see where the “Unknown” 999-999-9999 is coming from

Do you have CID Lookup enabled in FreePBX?

Open up a shell to the server, type asterisk -r then “set verbose 5”. Capture the output when you dial between two extensions.
Post the output here so that we can see where the CID is obtained from.

Thanks for the response. CID going between the extensions works fine. It’s using an outgoing SIP channel and trunk is when it starts acting up.

Here is a paste of calling with the trunk


As far as I can see you set the CID to “T <9560000000>” when you dial out. If what you receive is different then it is almost certainly your provider that does something odd with it.

Executing [s@macro-outbound-callerid:13] ExecIf("SIP/100-1063e7f0", "1|Set|CALLERID(all)=T <9560000000>") in new stack

dialparties.agi: Caller ID name is ‘Name Unavailabl’ number is '9999999999’
dialparties.agi: USE_CONFIRMATION: 'FALSE’
dialparties.agi: RINGGROUP_INDEX: ''
dialparties.agi: Methodology of ring is ‘none’

Why would that be set to that, and what can override it?

Ok, asterisk -r, set verbose 0 then agi debug. Do the same call. Post log file.