FPBX 17 fresh install getting the "Please Run: fwconsole reload --verbose" error

Fresh install using the script, all modules updated to latest version. I ran fwconsole chown. Wondering if there is anything else I should try?

This is what I get when running it from CLI as asterisk user.

# sudo -u asterisk fwconsole reload --verbose
Reload Started
Unable to access the running directory (Permission denied).  Changing to '/' for compatibility.
Unable to access the running directory (Permission denied).  Changing to '/' for compatibility.
Unable to access the running directory (Permission denied).  Changing to '/' for compatibility.
Unable to access the running directory (Permission denied).  Changing to '/' for compatibility.

In Network.class.php line 113:

  [Whoops\Exception\ErrorException (2)]
  file_get_contents(/etc/network/interfaces): Failed to open stream: Permission denied


Exception trace:
  at /var/www/html/admin/modules/sysadmin/Network.class.php:113
 Whoops\Run->handleError() at n/a:n/a
 file_get_contents() at /var/www/html/admin/modules/sysadmin/Network.class.php:113
...
...

/etc/network/interfaces is owner/group root with 660 permission. Changing it to 664 gets rid of the above error. Perhaps this permission change needs to be added to the install script and to fwconsole chown?

Run fwconsole as root

When looking up that error it was suggested to run as asterisk user to troubleshoot the cause.

fwconsole chown, which I run as root, does not get rid of the above error that only shows up when run as asterisk user.

Raised [bug]: FreePBX 17 reload issue · Issue #204 · FreePBX/issue-tracker · GitHub to keep track of this issue. Thanks

I just got the same error and i ran upgradeall via shell yet still have the same problem in my test box for v17

sudo -u asterisk fwconsole reload --verbose
Reload Started
Unable to access the running directory (Permission denied). Changing to ‘/’ for compatibility.
Unable to access the running directory (Permission denied). Changing to ‘/’ for compatibility.
Unable to access the running directory (Permission denied). Changing to ‘/’ for compatibility.
Unable to access the running directory (Permission denied). Changing to ‘/’ for compatibility.

In Pest.php line 232:

[Pest_Curl_Exec]
Failed to connect to 127.0.0.1 port 6001 after 0 ms: Couldn’t connect to server

Exception trace:
at /var/www/html/admin/libraries/pest/Pest.php:232
Pest->doRequest() at /var/www/html/admin/libraries/pest/Pest.php:364
Pest->post() at /var/www/html/admin/libraries/pest/PestJSON.php:46
PestJSON->post() at /var/www/html/admin/modules/sangomartapi/Sangomartapi.class.php:671
FreePBX\modules\Sangomartapi->nodeCall() at /var/www/html/admin/modules/sangomartapi/Sangomartapi.class.php:638
FreePBX\modules\Sangomartapi->nodeReload() at /var/www/html/admin/modules/sangomartapi/Sangomartapi.class.php:592
FreePBX\modules\Sangomartapi->postReloadFreepbx() at n/a:n/a
call_user_func_array() at /var/www/html/admin/libraries/BMO/Hooks.class.php:213
FreePBX\Hooks->processHooksByClassMethod() at /var/www/html/admin/libraries/Console/Reload.class.php:491
FreePBX\Console\Command\Reload->reload() at /var/www/html/admin/libraries/Console/Reload.class.php:95
FreePBX\Console\Command\Reload->execute() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Command/Command.php:312
Symfony\Component\Console\Command\Command->run() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:1022
Symfony\Component\Console\Application->doRunCommand() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:314
Symfony\Component\Console\Application->doRun() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:168
Symfony\Component\Console\Application->run() at /var/lib/asterisk/bin/fwconsole:163

In the module admin I see the tempered with warnings but trying to reinstall core i get this

root@pbx17:/home/jmf# sudo asterisk fwconsole ma refreshsignatures

Asterisk already running on /var/run/asterisk/asterisk.ctl. Use ‘asterisk -r’ to connect.
root@pbx17:/home/jmf# sudo asterisk fwconsole ma install core
Asterisk already running on /var/run/asterisk/asterisk.ctl. Use ‘asterisk -r’ to connect.
root@pbx17:/home/jmf# sudo asterisk fwconsole ma install core 2 -f
Asterisk already running on /var/run/asterisk/asterisk.ctl. Use ‘asterisk -r’ to connect.
root@pbx17:/home/jmf#

The asterisk user has reduced privilege, you should be root to install, sudo is not sufficient

When you do this from the UI I believe it runs as asterisk user, so running as asterisk from cli is a way to troubleshoot that.

In any ‘shell’, a sudo (do as switched user) environment is NOT necessarily identical to the environment encountered by a root login, you can compare any differences with env in both.

su root would be a better choice

okay thanks, I just gutted the entire vm and it’s reinstall 17 now. Not sure what happened after I did updates but all hell broke loose. I made snapshots this time

After the rebuild and importing of ext, trunk and DID it’s running well except for this

The Asterisk REST Interface is Currently Disabled.

I checked the username and password of ARI and nothing with odd characters

UNIT LOAD ACTIVE SUB DESCRIPTION
apache2.service loaded active running The Apache HTTP Server
chrony.service loaded active running chrony, an NTP client/server
cron.service loaded active running Regular background program processing daemon
dbus.service loaded active running D-Bus System Message Bus
fail2ban.service loaded active running Fail2Ban Service
[email protected] loaded active running Getty on tty1
haproxy.service loaded active running HAProxy Load Balancer
incron.service loaded active running file system events scheduler
mariadb.service loaded active running MariaDB 10.11.6 database server
mongod.service loaded active running MongoDB Database Server
[email protected] loaded active running Postfix Mail Transport Agent (instance -)
redis-server.service loaded active running Advanced key-value store
rsyslog.service loaded active running System Logging Service
ssh.service loaded active running OpenBSD Secure Shell server
systemd-journald.service loaded active running Journal Service
systemd-logind.service loaded active running User Login Management
systemd-udevd.service loaded active running Rule-based Manager for Device Events and Files
daemon…service loaded active running LSB: Starts or stops the xi

Check the Settings > Advanced settings to see if REST is enabled.

thanks, that was it. I don’t ever remember having to enable that in the past.

If you want to be as close as possible then you should use su - instead.