FreePBX | Register | Issues | Wiki | Portal | Support

Follow me doesn't work with ring group?


(Bgladdy) #1

Hello. I have two systems working flawlessly but I’m really pretty novice. I’ll try to make my question concise.

Nutshell: Follow me works when IVR points directly to an extension. Follow me fails if IVR points to a ring group containing same extension.

I had follow me successfully ringing my cell phone when IVR sends that call to my main office extension.

Recently I’ve installed a phone in a remote location. IVR wouldn’t reliably ring two extensions for the same button press from the caller so I pointed the IVR to a new ring group that rings local and remote locations.

Now that IVR points to ring group, Follow me doesn’t work. If I set IVR back to go to a single local extension, it works again.

I assume my understanding of how that module works is flawed. Any idea of setup for this or a workaround? Thanks for any help.


(Dave Burgess) #2

Follow Me follows an extension, but you’re not calling an extension, you’re calling a ring group. Unless the extensions time out before the ring group (which usually doesn’t happen because then the result is unpredictable), the ring group “fail” destination is where the call will end up.

Now, if the remote phone is set to Forward the call to the cell, that should work the way you are describing, since the extension is taking action based on the fact that it’s ringing. Does that help?


#3

Check this out.


(Bgladdy) #4

Thanks for the attention to my measly problem.

frankb: My settings already include the # following the number to my cell i.e. the outgoing call

cynjut: This makes sense, but makes this setup impossible? I’d like Follow Me to work normally, for my main office extension. Since I’m only at the remote location a few days of the month, i’d like it to be just a remote extension that rings simultaneously with my main extension.

I’m surprised this doesn’t work. My main line goes through an IVR and ring group and the follow me work fine on several extensions. Seems the second loop through a ring group kills the Follow me.

Normal flow:
Inbound route>Ring group>IVR>Extension>VM WORKS

Flow with off-site extensions added:
Inbound route>Ring group>IVR>Ring group>VM DOES NOT WORK

I can’t think of another route that would ring multiple extensions for one IVR user without a ring group. I tried adding two lines in the IVR for the same digit press (i.e. caller pushing “3” goes to two extensions) but that didn’t work reliably.


#5

You might want to rerread the post. It states to try the pound sign after your extension.


(Bgladdy) #6

I got this working in case any one else has the same issue. The fix was quite simple.

Inclusion or omission of a pound sign after the extension or outgoing follow me number made no difference in my setup.

However, changing order of the numbers makes it work properly i.e. follow me number first, local extension second in the Follow-Me List rather than the default local extension first.