Flowroute T.38 Fax Config

Hi all,

I’m having a bit of trouble setting up inbound fax from Flowroute on FreePBX15.0.17.12 with Asterisk 16.15.1. In the CLI, I see: FAXSTATUS=“FAILED: error: statusstr: OK”. Below is the call flow from a packet capture I did, and I’m noticing it says no-signal a lot, which I’m thinking is the issue, but I’m not sure how to fix it. The sending fax machine shows the fax was sent successfully every time. I opened UDP ports 4000-4999 on my firewall and have set T.38 passthrough = yes in Asterisk General SIP settings as well but not sure if that was necessary. The goal here is to have the inbound fax emailed as a PDF to the user.

This is my first time setting up fax on FreePBX so any help would greatly be appreciated!

Asterisk CLI Pastebin
Edit: PCAP Call Flow

Just thought I’d give an update:

I’m able to confirm that T.38 is working and also able to receive faxes reliably. Sending faxes don’t work. I’ve purchased the Fax Pro module and am trying to send faxes through UCP.

Would really appreciate some troubleshooting guidance!


I am having a similar issue. I just turned up a new system last Friday running FreePBX, current Asterisk version 16.15.1.

Through the UCP, inbound faxes are working, but every outbound fax fails with “The call terminated prematurely.”

I have many other customers who use Efax and have the FaxPro Module.

But this is the first time I have encountered this.

To me, this indicates a negotiation issue for the fax…

I am running only PJSIP and registering the PBX to FlowRoute.

Didn’t see this issue with previous versions.

Try sending the fax with standard resolution. It might be that the fax machine in the other end can not accept high resolution fax

Thank you. Same result. Most faxes have to “retry” before they fail, and the reason is “the call dropped prematurely.” The few that do say “sent” have a status of “answer,” but the actual fax doesn’t go through.

So weird because I have many customers that use this, I have mirrored the configs. This is a new deployment since last Friday.

I’m seeing this same issue with one of my deployments of FreePBX 15 with Asterisk 16 (all up-to-date). The users used to be able to send faxes from the UCP without issue, but now 95% of them fail with that same error; "“The call dropped prematurely.” Everything was fine until around the end of September last year when I started getting reports of failures. The issue is still not resolved. Does anyone have additional insight on what this error is actually indicating?



So, I worked with Sangoma on this and FlowRoute. Ticket# 974463

With all of the PCAPS examined, they determined that my PBX is dialing out and establishing a call, but when the remote end requests information, my PBX is not responding on outbound calls.

2/10/2021 Sangoma: I understand your concern, this is known issue: https://issues.asterisk.org/jira/browse/ASTERISK-29035

2/10/20201 Sangoma: This issue was caused by asterisk, in coming few weeks, there will be new version of asterisk that permanently fix this outbound fax failing issue. it will show you when you run ‘yum check-update’ .

FlowRoute: Everything in the SIP signaling set up looks good.
They are saying that your PBX is receiving the correct fax signaling and just not responding. I’d be happy to take a look at the fax signaling as a second pair of eyes if you can provide me with a pcap that includes media.

I just deployed a new server to resolve the issue: FreePBX running Asterisk 16.15.1

I am having the same issue on FreePBX Asterisk 16.15.1 and Flowroute trunk
T.38 incoming works well.
T.38 outgoing fails when Asterisk stops responding during initial call setup.
When outgoing T.38 fax is attempted, packet capture shows the resultant SIP followed by RTP traffic. Once the T.38 packets arrive, Asterisk stops responding.

Did your deployment of FreePBX running Asterisk 16.15.1 resolve the issue?
Asterisk shows the issue being addressed in 16.17.0 which is currently in RC status.

Im having the same issue and have a ticket open with support Sipstation and another thread here on this same issue. Support is saying exact same thing, my system is not responding…

Sangoma Asterisk Technician replied in my other thread and said Asterisk outbound faxing is indeed broken. He said it will be a few weeks before the Asterisk update that fixes this lands in FreePBX… Just an fyi. Here’s link to my thread with this same issue and his response…

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.