Fax Pro SipStation Outgoing Failing


(Defcomllc) #1

I am just setting up Fax Pro for the first time. Created Outbound and Inbound routes. Im using SipStation…T.38 approved DID… T38 turned on in SipStation My Account settings.

T.38 Enabled in Asterisk Sip Settings

Global Route Prefix set to *323

Sending in UCP fails… Says “The Call Dropped Prematurely.”

I can receive faxs no problem. Any help on what I have setup wrong ?

Imgur
Imgur


Flowroute T.38 Fax Config
(Defcomllc) #2

I’ve been testing this for 20hr now… still can’t get outgoing to work…driving me nuts


(Defcomllc) #3

Is anybody using Fax Pro with SipStation and successfully sending outbound faxes??


(Defcomllc) #4

So I created a Sipstation support ticket and this is the what they are telling me…

"We dug into the calls and believe we found the problem. After the t.38 training is complete, we don’t get a response to t.38 media. We are retrying 5 times but never getting a response. Either the initial traffic isn’t getting to your PBX or your PBX is not responding. I attached the PCAP from the test you made today where you can see us sending you the traffic but never getting a response."

Do I need to open ports for out going faxing??


(Joshua C. Colp) #5

You’re encountering an Asterisk issue[1]. The releases tagged are currently in release candidate status for testing. A user has reported one regression so we’ll be doing another set of release candidates, after which if all goes well full releases will occur. I would expect it to be a few weeks before it lands in FreePBX.

[1] https://issues.asterisk.org/jira/browse/ASTERISK-29035


(Defcomllc) #6

Ok so its nothing on my end… Support just had me open 4000-4999 from their IP but same results, “The call dropped prematurely.”

So in a future update in the next few weeks this problem will just go away? and outgoing faxes will start going through? I just want to make sure I understand what your saying so Im not wasting mine or supports time trying to troubleshoot an unfixable (at the moment) issue outside of our control?

Appreciate the reply.


(Joshua C. Colp) #7

Your screenshots show a Local channel in use, which is broken. Once updated to the fixed Asterisk version then Local channels used with T.38 will work once again. I don’t think there’s any need to troubleshoot further.

If you could eliminate the Local channel then it would also work. How to do that in FreePBX land I do not know.


Inbound faxes ext-fax hangup - no fax received
(Defcomllc) #8

Appreciate the information. Ill wait and keep updating my FreePBX. Hopefully in the next few weeks its fixed and working. Thanks again.


#9

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(Defcomllc) #10

Really frustrating we still havent seen the Asterisk update within FreePBX updates to fix this faxing issue so we can get back to sending faxes with Fax Pro module…I thought we would have seen the update already as its been almost a month since Asterisk fixed it.


(Lorne Gaetz) #11

If you’re waiting for Asterisk versions 16.17.0 and 18.3.0, they were published less than 2 weeks ago. We have an internal ticket on this, and I expect to see rpms published to our testing repos shortly.


(Defcomllc) #12

Thank you for the update @lgaetz


(Lorne Gaetz) #13

att: @defcomllc
https://community.freepbx.org/t/queue-agents-invalid-when-there-is-a-single-agent/73591/7?u=lgaetz


(Defcomllc) #14

@lgaetz Thank you for the heads up. How do I go about installing these versions of Asterisks since they arent available via Updates module? Id be more than glad to test them out and see if they fix the T.38 fax issue as Asterisk has stated… I assume from CLI??


(Defcomllc) #15

Running Yum update just says no packages marked for update. I know Im missing something here…


(Defcomllc) #16

I ran asterisk-version-switch and none of the listed options are 16.17 or 18.3… Just 16.16 and 18.2…


(Defcomllc) #17

So I have Asterisk 16.17 installed and T.38 faxing issue is resolved. I can now sucessfully send outgoing faxes. Now to just wait for it to be released in a stable repo…

Since this is the first time running a Sangoma Testing repo… Should I switch back to 16 (LTS) 16.16.2 since Im testing this on my main production system? Or is it ok to keep running this testing repo without issue?


(Itzik) #18

AFAIK, you can just remove that repo, unless you have trouble with the current Asterisk version

yum remove sangoma-devel

(Defcomllc) #19

Yes I did know how to remove it. I was more asking should I remove it from this production box since it’s a test repo? For stability reasons…or is it OK to keep running till a major release comes out with 16.7?