Fclose 110 is not a valid stream resource

PBxact version 14 is not making or recieving calls, internally or externally. Phones show registered. When I restart the system, it worked for a couple hours. I ran fwconsole restart and it says In php-asmanager.php line 489: fclose () : 110 is not a valid stream resource. This is happening on another system as well, except it says 111 is not a valid stream resource. What is going on?

fclose error is one of the symptoms of the recent asterisk issue here:

Thanks! that worked for the freepbx system. The pbxact sytem was on asterisk 15.7.2. When I ran command to downgrade to 13 it says not match for available package astersisk xxxxxxxx sng7 Nothing to do. So i’m running the sangoma-devel command now but I assume I’ll want to roll back to stable once the issue is resolved. How do I do that?

Got the sangoma-devel upgrades installed, ran fwconsole restart and get the same error. Asterisk is still running and we can’t stop it! fwconsole stop I get the same In php-asmanager.php line 489: fclose () : 110 is not a valid line stream resource. Now what?

I’ll bet you can. The unit is plugged in, right? There’s a sure way to absolutely stop Asterisk based on manipulation of the power cord. If you can get to the Command Line on the console, you can also issue the command “reboot -n”, which will also stop Asterisk.

That’s the messsage it gives in the cli. But shutdown -r now did restart it and its working now, but how do I know that it’s fixed (as in repaired, not an immovable object)

You can log into the console and issue ‘asterisk -vr’. You will get the Asterisk version there. That should tell you is the version update completed successfully. You may need to use the asterisk-version-switch command again to upgrade to 16 or downgrade to 13 again. If you downgrade to your current version, the script will tell you so.

I’m glad you got it resolved. Meanwhile, it looks like shoddy programming to me.

When you run fopen it should return either the file pointer or “FALSE” if it got an error.
The reason that fclose would throw that error is if the stream wasn’t successfully opened.

… which can be tested with a simple IF statement to see if the value returned from fopen was “FALSE” or not.

It’s because the stream died after being connected to.

I should have said “If the stream wasn’t successfully opened or was for some other reason closed or disconnected”.

Now UCP doesn’t work. I get

Whoops\Exception\ErrorException Maximum execution time of 30 seconds exceeded

its on 12.7.6-1904-1.sng7

What version of asterisk as your asterisk is continually crashing


So I switched to asterisk 13.26.0 and still get the same page.

What next?

Did you report this as a bug?

This isn’t a bug. Not everything is a bug.

I reported and the suggested solution of fwconsole ma install ucp did not make a difference. I ran fwconsole restart and still get the Whoops error page. The bug report is marked closed. Do I need to re open ticket, or will I get an answer on here, since apparently it isn’t a bug?

On your system freepbx is unable to talk to asterisk or the connection is very slow. I’d suggest a reinstall. Submitting this as a bug won’t fix your issue because it’s not reproducible. The ticket system is not a free support system.