Fax issues starting around October 6

We know that fax over PRI and SIP trunks is not 100% reliable.
We have been setting light-fax systems up this way for years without issues.

We have one location where inbound/outbound fax using SPA112 ATAs has been working without issue since Feb 2018. It worked fine on October 5. Since then it’s been very erratic; once in a while it works. Mostly it does not. Sometimes it connects and doesn’t negotiate. Sometimes it negotiates and sends some of the pages, then fails, etc. It’s erratic.

We have tried:

  • Swapping out like SPA112s
  • Downgrading SPA112 firmware
  • Standing up a SIPStation trunk and routing faxes over it
  • The above with T.38 enabled on the trunk
  • A Grandstream HT-802 ATA
  • Moving the ATAs from the wiring closet to the fax machines (to address possible cabling issues)
  • Different fax machines (MFPs) in different physical locations in the office.

Install info:
Asterisk 13.38.3
All modules up to date on Standard track
Comcast PRI with Digium G100 interface
SIPStation trunk with and without T.38 enabled

We aren’t seeing this sending or receiving with Fax Pro within FreePBX.

SIPStation support looked at packet traces and indicated that there is a protocol problem; a “not allowed” is being returned during the comms. I’ve requested the exact syntax of the error.

Again, this was problem-free until October 6. The only variable remaining seems to be FreePBX itself.

Any ideas? I’m about out of hair.

Edit to add: I registered the ATA directly to the SIPstation trunk and it works fine that way. Starting to look like some weird issue with FreePBX.

So the underlying issue would be with asterisk because that’s what’s handling all of the audio etc. The question would be, have you updated asterisk?

Asterisk 13 has been security only for the last year and essentially goes end of life completely next week. I would probably suggest getting on one of the newer versions of asterisk as a test.

Being that you are using a t1 card it is possible that or something there as well. Maybe the echo cancellation is running during your fax which will hose things up pretty properly.

All around I would make sure you were up to date as the first test because any bugs that exist may have already been fixed

A little confusing, are your fax calls that are failing coming over your PRI or your SIP trunk?

1 Like

If you suspect the PBX, confirm that by configuring an SPA112 to connect directly to a SIP trunk, bypassing the PBX. If you only need to test outgoing, the SPA can be set to not register, so it won’t interfere with production use of the trunk.

If it still fails without the PBX, you could test on a different internet connection, e.g. at home, or with a different trunking provider (many offer free trials).

However, given that Fax Pro is working reliably, now would be a good time to ditch the obsolete fax machine. See my post

Edit: Sorry, I missed your edit about bypassing the PBX. Paste a log of a failing call including a SIP trace, so we can check for transcoding or a similar issue. If that’s all clean we can capture traffic to see whether packet loss or excessive jitter is being introduced. If that also looks good we can capture traffic at the device or your router/firewall to see how the RTP is getting messed up.

There are no system updates available. If this version will support a newer version of Asterisk and the ‘change on the fly’ feature still exists I will do that. Been a long while since I used that feature.

We aren’t. Digium G100 device for the interface, so FreePBX just sees SIP.

Has been setup for years using a PRI. Got a SIPStation trunk to try to isolate the problem. So have tried both with the same result. Inbound and outbound are okay using FaxPro. Neither work using the ATA (PRI or SIP).

That was done on the SIPStation side, case #1004544

Asterisk options are:
Asterisk 13 (EOL)
Asterisk 13 Certified (EOL)
Asterisk 15 (EOL)
Asterisk 16 (LTS)
Asterisk 17 (S)
Asterisk 18 (LTS)

What is the official recommended version at this time?

The most mature, current supported LTS version is 16.

Thank you, Lorne. I’ve switched to that one, will test today, and report back here in case anyone else runs into this.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.