Externa Digium Phones can't connect to FreePBX


#1

Using FreePBX 13.0.197.28
Digium Addons 2.11.0.14
DPMA 3.4.1

The FreePBX server is at the HQ.

And we have one remote location with 3 Digium Phones.

Wednesday this week, the Digium Phones started being unable to connect.

I tried factory resetting one, and entering the Digium configuration server address (IP of the HQ), and I get the message “No Configuration Servers”.

I’ve been trying to figure out if this is a firewall issue.

The remote office IP is in pfSense (the HQ firewall) whitelist.
This IP is also in the whitelist of FreePBX Intrusion Detection.

I’m not sure of what to look for here and I’d like to understand why we can’t connect remotely anymore.

Thanks!


(Lorne Gaetz) #2

Your phones don’t appear to be able to reach the DPMA service running on the PBX.

But you have a more serious issue to deal with. Your DPMA version is out of date and the built in SSL cert will expire in a few weeks. You need to get DPMA upgraded asap:


#3

Thank you for your reply.

I did a yum update and it seems DPMA was upgraded to 3.4.13-1.shmz65.1.51

I rebooted the server completely.

I can connect the phones again!

However I still get the following message in the dashboard:

An outdated version of the Asterisk DPMA module was detected (v3.4.1) . Please upgrade to a supported version (v3.6.2+) to ensure uninterrupted usage of DPMA supported phones.


(Lorne Gaetz) #4

Confirm the running DPMA version is current and then dismiss the dashboard notice.


(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.