Extensions going offline freepbx 15 chan-sip

I had this problem on this same pbx when i first set it up using pjsip, so i switched to chan-sip and never had the problem again, now about a year later its showing its ugly head again. Endpoint manager shows extensions registered, if i login in to the phone gui itself, it says registered, but if i go to the pbx and do a show sip peers it shows status unreachable. any ideas?

Typically when I run into this it’s a networking issue.

Are your phones and your PBX on the same LAN?

cloud hosted freepbx 15, chan-sip extensions, port 5060
phones all at one premise

No, they are not. Yeah, I just discovered that the customer put in a new router and didn’t let me know about it…so probably the cause of the issues.

Yes, very likely some NAT time out settings that you’ll need to look at. Also make sure that if SIP ALG is enabled by default on the router that it’s turned off.

enabled udp timeouts to 600sec, opened 5060 and 10k-20k ports to freepbx ip, but still no luck, some phones are showing status OK and some are not.

What’s the new firewall?

unifi dream machine pro

I noticed extensions with ports around 23000 are all showing unreachable, but ones under 20k and over 30k are ok.

nevermind, 100 just went to unreachable too:

100/100 x.x.x.x D Yes Yes A 15318 UNREACHABLE

Try increasing the UDP Stream timeout in the UDM to 300: https://community.ui.com/questions/UDM-Pro-UDP-settings/7c407909-0091-4024-8b18-74bcc7236ad4 . If that’s what you changed to 600, leave it at 600.

Then, reduce the registration expiry in the devices to 120.

If you still have trouble, report phone make/model, and whether the the device comes back online at the next registration attempt.

already increased it to 600, still same problem exists.

It also appears to only be affecting really old yealink t20, t21 & t28 phones. None of the newer Grandstream ones are having any issues.

Have you checked if there is newer firmware for these phones?

Did you also set Server Expires in the Yealink phones to 120?

server expires to 120 seems to be the solution, thx guys

yes, they’re on the latest firmware (which is still 8 years old lol)

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.