Extensions go directly to voicemail

I have a new Asterisk install (v1.2.7.1) running on ubuntu 6.06, with FreePBX 2.5.1.1. I have successfully configured my external SIP trunk, and I can call out using that trunk. But if I call from extension to extension (7002 to 7000) the call goes directly to voicemail. If I configure an inbound route to route the SIP trunk to an extension, the call goes directly to voicemail. I have deleted and recreated the extensions, with no luck. FOP shows all green. When I output a verbose log, I get this,

– Executing Set(“SIP/7002-476a”, “__RINGTIMER=9”) in new stack
– Executing Macro(“SIP/7002-476a”, “exten-vm|7000|7000”) in new stack
– Executing Macro(“SIP/7002-476a”, “user-callerid”) in new stack
– Executing Set(“SIP/7002-476a”, “AMPUSER=7002”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “0?report”) in new stack
– Executing ExecIf(“SIP/7002-476a”, “1|Set|REALCALLERIDNUM=7002”) in new stack
– Executing Set(“SIP/7002-476a”, “AMPUSER=7002”) in new stack
– Executing Set(“SIP/7002-476a”, “AMPUSERCIDNAME=Test 2”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “0?report”) in new stack
– Executing Set(“SIP/7002-476a”, “AMPUSERCID=7002”) in new stack
– Executing Set(“SIP/7002-476a”, “CALLERID(all)=“Test 2” <7002>”) in new stack
– Executing Set(“SIP/7002-476a”, “REALCALLERIDNUM=7002”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “0?continue”) in new stack
– Executing Set(“SIP/7002-476a”, “__TTL=64”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing NoOp(“SIP/7002-476a”, “Using CallerID “Test 2” <7002>”) in new stack
– Executing Set(“SIP/7002-476a”, “RingGroupMethod=none”) in new stack
– Executing Set(“SIP/7002-476a”, “VMBOX=7000”) in new stack
– Executing Set(“SIP/7002-476a”, “EXTTOCALL=7000”) in new stack
– Executing Set(“SIP/7002-476a”, “CFUEXT=”) in new stack
– Executing Set(“SIP/7002-476a”, “CFBEXT=”) in new stack
– Executing Set(“SIP/7002-476a”, “RT=9”) in new stack
– Executing Macro(“SIP/7002-476a”, “record-enable|7000|IN”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “1?check”) in new stack
– Goto (macro-record-enable,s,4)
– Executing AGI(“SIP/7002-476a”, “recordingcheck|20090219-033346|1235014426.3”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
– AGI Script recordingcheck completed, returning 0
– Executing MacroExit(“SIP/7002-476a”, “”) in new stack
– Executing Macro(“SIP/7002-476a”, “dial|9|tr|7000”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “1?dial”) in new stack
– Goto (macro-dial,s,3)
– Executing AGI(“SIP/7002-476a”, “dialparties.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
– AGI Script dialparties.agi completed, returning 0
– Executing NoOp(“SIP/7002-476a”, "Returned from dialparties with no extensions to call and DIALSTATUS: ") in new stack
– Executing GotoIf(“SIP/7002-476a”, “0?exit|return”) in new stack
– Executing Set(“SIP/7002-476a”, “SV_DIALSTATUS=”) in new stack
– Executing GosubIf(“SIP/7002-476a”, “0?docfu|1”) in new stack
– Executing GosubIf(“SIP/7002-476a”, “0?docfb|1”) in new stack
– Executing Set(“SIP/7002-476a”, “DIALSTATUS=”) in new stack
– Executing NoOp(“SIP/7002-476a”, “Voicemail is 7000”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “0?s-|1”) in new stack
– Executing NoOp(“SIP/7002-476a”, “Sending to Voicemail box 7000”) in new stack
– Executing Macro(“SIP/7002-476a”, “vm|7000||”) in new stack
– Executing Macro(“SIP/7002-476a”, “user-callerid|SKIPTTL”) in new stack
– Executing Set(“SIP/7002-476a”, “AMPUSER=7002”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “0?report”) in new stack
– Executing ExecIf(“SIP/7002-476a”, “0|Set|REALCALLERIDNUM=7002”) in new stack
– Executing Set(“SIP/7002-476a”, “AMPUSER=7002”) in new stack
– Executing Set(“SIP/7002-476a”, “AMPUSERCIDNAME=Test 2”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “0?report”) in new stack
– Executing Set(“SIP/7002-476a”, “AMPUSERCID=7002”) in new stack
– Executing Set(“SIP/7002-476a”, “CALLERID(all)=“Test 2” <7002>”) in new stack
– Executing Set(“SIP/7002-476a”, “REALCALLERIDNUM=7002”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing NoOp(“SIP/7002-476a”, “Using CallerID “Test 2” <7002>”) in new stack
– Executing Set(“SIP/7002-476a”, “VMGAIN=”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “1?vmx|1”) in new stack
– Goto (macro-vm,vmx,1)
– Executing GotoIf(“SIP/7002-476a”, “0?s-|1”) in new stack
– Executing Set(“SIP/7002-476a”, “MODE=unavail”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “1?notdirect”) in new stack
– Goto (macro-vm,vmx,5)
– Executing NoOp(“SIP/7002-476a”, "Checking if ext 7000 is enabled: ") in new stack
– Executing GotoIf(“SIP/7002-476a”, “1?s-|1”) in new stack
– Goto (macro-vm,s-,1)
– Executing Macro(“SIP/7002-476a”, “get-vmcontext|7000”) in new stack
– Executing Set(“SIP/7002-476a”, “VMCONTEXT=default”) in new stack
– Executing GotoIf(“SIP/7002-476a”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing NoOp(“SIP/7002-476a”, “”) in new stack
– Executing VoiceMail(“SIP/7002-476a”, “[email protected]|su”) in new stack
– Playing ‘vm-theperson’ (language ‘en’)
– Playing ‘digits/7’ (language ‘en’)
– Playing ‘digits/0’ (language ‘en’)
– Playing ‘digits/0’ (language ‘en’)

Can someone help me translate this, so that I can fix this issue.
Thanks!
Linuxx

Hum, Phone will not ring. Is it registered? If so next check for DND being enabled. If not registered please re-check your configuration as you missed something (sorry can be more specific due to nothing to look at).

More important: This might be a new build but it’s using VERY old code: If you want to use the asterisk 1.2 branch please at least use the latest code so that you are not compromised for any of the available ones for that version. At the same time you don’t start complaining about possible bugs that are known and addressed as fixed in the later code versions.

Both phones are logged in and registered, with DND not enabled. I was thinking it was the version I was running, I will upgrade to the latest and try again. 1.2 is the version you receive when you “apt-get install asterisk” from Ubuntu 6.06.

Linuxx

Well so that you know * 1.2.7 is well over two years old (probably three). The 1.2 branch is currently at 1.2.31. 1.2.12.1 was released back on Sept. 15 2006, the furthest back I could go in history of release notes at http://www.asterisk.org/taxonomy/term/29?page=10

Upgraded to Ubuntu 8.10, and Asterisk 1.4.21 now everything works. Thanks for your help.

Linuxx