Ext -> FM -> Ring Group -> Ring Group forwarding not working anymore


(Nederland) #1

Some extensions in my organization are set up as follows:

DID -> Extension (768) -> Ring group of direct colleagues (310) -> Ring group of direct colleagues and reception (311)

The goal is that if a customer calls an extension which is not picked up, first a colleague will answer, then the reception or a colleague.

  • In [Settings] -> [advanced settings] the general ring time default is set to 120secs
  • The extensions Follow Me Initial ring time is set to 7 seconds, with a 60 second FM ring time.
  • The first ring groups ring time is set to a ring time of 15 secs with ring group 311 for no answer destination.

If I directly call the first ring group (310), forwarding to the second ring (311) group works fine.
If I call the extension (768), the FM to the first ring group works (310), but the call isn’t forwarded to the second ring group (311).

This used to work fine when I set the PBX up about 6 months ago, any ideas what could be the cause of it not working anymore?

Would it be necessary to forward the DID to a ring group with only the first extension in it, which then forwards to 310? (As described here Forwarding DID->Extension routes to operator queue if unanswered )


(Itzik) #2

A call log would tell whats up

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Nederland) #4

Thanks, heres a log: https://pastebin.com/hKg0TRW5
It was too big to paste in the post


#5

You have the DID going to an ext and it looks like its not going to no answer by the time the 310 ring group ends.

To make it a little simpler you can make the DID go to 310 ring group and then list the extensions, setting it to Hunt. It will go to the next available extension going down the list. Instead of putting the 311 ring group in No Answer, just put it in the extension list with “311#”.

I’m not quite sure if this will skip busy extensions or not, you may not want that. But it might skip an extension in use and move on to the next one.


(Itzik) #6

I didn’t review the logs in detail. I think you should do the following:

  • On extension 768. Add to the FollowMe list all direct colleagues. (If you want it should ring by 768 first before ringing the direct colleagues as well, then adjust the initial ring time)
  • Set the FollowMe no answer destination to a Ring Group which has 768, direct colleagues and reception
  • Then you can set the ring group no answer destination to voicemail etc.

Makes sense?


(Nederland) #7

@PitzKey, Hey Thanks, that makes sense and will work!

@K1miz, hunt style isnt what I’m after here (this isnt a callcenter but specific acct managers), but directing the DID to a 1-person call group with overflow to a broader call group will also work.


(system) closed #8

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.