Every Morning "All Circuits are busy try your call again later"

Man anything anyone can offer would be great. I am at my wits end with this. I’m ready to switch from 2Talk.com already since I believe this to be an issue with their system.

Well, you could take a number with another supplier and see it the issues persists on that number. If not, it’s like the ITSP.

You could also schedule a cron job to reload asterisk every couple of hours. It’s a patch, but may do the trick.

1 Like

I’ve actually done this for a customer for a different problem (IP routing for a routable interface with two addresses). Schedule a reload in cron every six hours and you should be good to go - set them to happen at 6 if you just want to “prime the pump”.

I’m gonna wing it:

: * 6 * * * * asterisk -vc “core reload”

Might do the trick. I’m away from my PBX right now, so you may need to futz with it a little. Let me know and I’ll fix whatever errors there are.

What will this “Core Reload” do to fix the problem? Is it basically just restarting the system every so many hours? So are you thinking that for whatever reason the system looses connection and can’t reconnect?

Yup. That’s what I think. The connection has been unused for a few hours and someone in your supply chain is dropping the connection. Doing a reload should restart all of the dropped connections. If they aren’t dropped, no harm. If they are dropped, they should come back up.

Dumber things have worked for problems like this.

How would I type this command manually using root access? I can try to do this whenever I can’t get an outgoing line and then if it works I can make it a cronjob.

Log in as ‘root’ and you can type “fwconsole reload” or “amportal reload” (depending on your particular installation). Both of those should start the juices flowing. You could try “restart” instead of “reload” and see if that helps.

If you want something a little more “SIP centric” you could try some of the following (still logged in as ‘root’).

# asterisk -vx “sip reload”
# asterisk -vx “core reload”

https://www.voip-info.org/wiki/view/Asterisk+CLI has a lot of good information about the Asterisk CLI.

The idea, though, is to “wake up” the system and all of the parts to your ITSP before your first phone call in the morning.

Thank you. I tried it and no luck. This is now happening throughout the day without any rhyme to reason. Do you have any suggestions on how I should approach 2Talk.com. I really feel that at this point it’s got to be on their side.

Or could this some how be my Firewall? Can I turn off my Firewall to see it that fixes it and then turn it back on?

Also could this be my Netgear Router?

I just disabled SIP ALG on my router and now it seems to be working fine. Let’s see how long it lasts? What do you think, could this have been the problem this whole time?

YES it could. SIP ALG should always be turned off… It messes with the IP adresses.

Yeah - that would do this too.