FreePBX | Register | Issues | Wiki | Portal | Support

Error updating core module


(United Kingdom) #1

Hi,

I am trying to update the Core module from 14.0.5.9 to 14.0.25.4 and have done the following:

Chosen Admin>Module Admin
Selected ‘Core’ in the applications section
Selected the ‘Upgrade’ action
Clicked on process
Clicked on confirm

A modal pops up saying installing but almost immediately afterwards a get an error debug screen (attached)

I seems it’s performing a database modification and adding fields to the incoming table but somehow there is a duplicate entry for a primary field. Will I need to run a SQL script to resolve the issue and if so what do I need to do? Hopefully it’s a known issue with a fully documented resolution!

Thanks in advance
James


(Itzik) #2

Try from bash

fwconsole ma downloadinstall core --force

If it completes successfully, reload

fwconsole reload

(United Kingdom) #3

Hi,

Thanks for your reply. I tried the command and had the same error (see below):


(Itzik) #4

I recently sew a few times the MYSQL 23000 error ‘PRIMARY’ after every call on some PBXs.

Anyone knows what causes this?

In the meantime, if there’s no active calls try running

service mariadb restart

And then try to run the previous command.


(United Kingdom) #5

Hi PitzKey,

I restarted mariadb and tried ‘fwconsole ma downloadinstall core --force’ but still the same error.

Thanks


(Lorne Gaetz) #6

@jamesk

Take a look at your inbound routes, it looks like there may be a duplicate entry or something else going on there.


(Dave Burgess) #7

If you are MySQL trained, you can remove the duplicate yourself using the MySQL Command Line. Start your search with a SELECT * FROM incoming WHERE cidnum LIKE “0120%” . Note that this solution is definitely for DB-Trained killers only.

Note that this may cause other issues in the system, so be prepared to troubleshoot weird one-off problems.


(United Kingdom) #8

Hi Igaetz,

I can’t access inbound routes from the menu anymore since I tried the update (menu below):
freepbx_error3


(United Kingdom) #9

Hi Cynjut,

I deleted the duplicate and now the core module updates correctly. Thank you very much and also thanks to Igaetz for his help.

James