Error after Upgrade Disabled Pending Downgrade


(Scrandall) #1

We upgraded from 14 to 15 via command line. We are getting this message in the “Admin -> Updates Modules” screen:

“PBX Upgrader 14.0.11 Stable Sangoma Technologies Corporation Commercial Disabled; Pending Downgrade to 14.0.5”.

It’s doesn’t seem to be causing any issues, but it would be nice to fix it so the error doesn’t show on the Dashboard as a disabled module. Thanks for any suggestions.


(Communication Technologies) #2

Doesn’t seem one-click easy to downgrade a module:

But it is possible. Given the role of the PBX Upgrader, especially if you are not seeing any service\performance issues, is to leave it alone. My 2 cents.


(Lorne Gaetz) #3

Please provide the output from:

fwconsole ma list

(Scrandall) #4

Here is the output from fwconsole. Strange that the fwconsole output says “…pending Upgrade…”, but the GUI Update screen says “…Downgrade…”

No repos specified, using: [standard,extended,commercial,unsupported] from last GUI settings
+----------------------+------------+-------------------------------------+-------------+
| Module               | Version    | Status                              | License     |
+----------------------+------------+-------------------------------------+-------------+
| accountcodepreserve  | 13.0.2.2   | Enabled                             | GPLv2       |
| amd                  | 15.0.2     | Enabled                             | GPLv3+      |
| announcement         | 15.0.3.10  | Enabled                             | GPLv3+      |
| api                  | 15.0.3.7   | Enabled                             | AGPLv3+     |
| areminder            | 15.0.14.22 | Enabled                             | Commercial  |
| arimanager           | 15.0.3.8   | Enabled                             | GPLv3+      |
| asterisk-cli         | 14.0.1     | Enabled                             | GPLv3+      |
| asteriskinfo         | 15.0.10    | Enabled                             | GPLv3+      |
| backup               | 15.0.10.28 | Enabled                             | GPLv3+      |
| blacklist            | 15.0.2.10  | Enabled                             | GPLv3+      |
| broadcast            | 15.0.12    | Enabled                             | Commercial  |
| builtin              |            | Enabled                             |             |
| bulkhandler          | 13.0.19    | Enabled                             | GPLv3+      |
| calendar             | 15.0.4.19  | Enabled                             | GPLv3+      |
| callaccounting       | 15.0.20    | Enabled                             | Commercial+ |
| callback             | 15.0.9     | Enabled                             | GPLv3+      |
| callerid             | 15.0.15    | Enabled                             | Commercial  |
| callforward          | 15.0.10    | Enabled                             | AGPLv3+     |
| calllimit            | 15.0.5.5   | Enabled                             | Commercial  |
| callrecording        | 15.0.7.11  | Enabled                             | AGPLv3+     |
| callwaiting          | 15.0.4.2   | Enabled                             | GPLv3+      |
| campon               | 13.0.4.1   | Enabled                             | GPLv3+      |
| cdr                  | 15.0.17.1  | Enabled                             | GPLv3+      |
| cel                  | 15.0.15.8  | Enabled                             | GPLv3+      |
| certman              | 15.0.25.3  | Enabled                             | AGPLv3+     |
| cidlookup            | 15.0.17    | Enabled                             | GPLv3+      |
| conferences          | 15.0.7.4   | Enabled                             | GPLv3+      |
| conferencespro       | 15.0.3.15  | Enabled                             | Commercial  |
| configedit           | 13.0.7.1   | Enabled                             | AGPLv3+     |
| contactmanager       | 15.0.8.23  | Enabled                             | GPLv3+      |
| core                 | 15.0.12.17 | Enabled                             | GPLv3+      |
| cos                  | 15.0.9     | Enabled                             | Commercial  |
| customappsreg        | 15.0.13    | Enabled                             | GPLv3+      |
| customcontexts       | 13.0.3.1   | Enabled                             | GPLv2+      |
| cxpanel              | 15.0.4     | Enabled                             | GPLv3       |
| dahdiconfig          | 15.0.5.4   | Enabled                             | GPLv3+      |
| dashboard            | 15.0.5     | Enabled                             | AGPLv3+     |
| daynight             | 15.0.11    | Enabled                             | GPLv3+      |
| dictate              | 15.0.6     | Enabled                             | GPLv3+      |
| digium_phones        | 15.0.2     | Enabled                             | GPLv2       |
| digiumaddoninstaller | 13.0.1.1   | Enabled                             | GPLv2       |
| directory            | 15.0.16    | Enabled                             | GPLv3+      |
| disa                 | 15.0.4.7   | Enabled                             | AGPLv3+     |
| donotdisturb         | 15.0.6     | Enabled                             | GPLv3+      |
| dundicheck           | 2.11.0.3   | Enabled                             | GPLv3+      |
| endpoint             | 15.0.27.30 | Enabled                             | Commercial  |
| endpointman          | 14.0.2.1   | Enabled                             | GPLv3+      |
| extensionroutes      | 15.0.5     | Enabled                             | Commercial  |
| extensionsettings    | 13.0.4     | Enabled                             | GPLv3+      |
| fax                  | 15.0.19    | Enabled                             | GPLv3+      |
| faxpro               | 15.0.8.11  | Enabled                             | Commercial  |
| featurecodeadmin     | 13.0.6.4   | Enabled                             | GPLv3+      |
| filestore            | 15.0.3.9   | Enabled                             | AGPLv3      |
| findmefollow         | 15.0.22    | Enabled                             | GPLv3+      |
| firewall             | 15.0.6.19  | Enabled                             | AGPLv3+     |
| framework            | 15.0.16.67 | Enabled                             | GPLv2+      |
| freepbx_ha           | 13.0.11    | Enabled                             | Commercial  |
| fw_langpacks         | 14.0.1     | Enabled                             | GPLv3+      |
| hotelwakeup          | 15.0.5.4   | Enabled                             | GPLv2       |
| iaxsettings          | 15.0.6     | Enabled                             | AGPLv3      |
| infoservices         | 15.0.2     | Enabled                             | GPLv2+      |
| irc                  | 13.0.1     | Enabled                             | GPLv3+      |
| ivr                  | 15.0.26    | Enabled                             | GPLv3+      |
| languages            | 15.0.10    | Enabled                             | GPLv3+      |
| logfiles             | 13.0.10.8  | Enabled                             | GPLv3+      |
| manager              | 15.0.9     | Enabled                             | GPLv2+      |
| miscapps             | 15.0.8     | Enabled                             | GPLv3+      |
| miscdests            | 15.0.2.10  | Enabled                             | GPLv3+      |
| motif                | 13.0.3.2   | Enabled                             | GPLv3+      |
| music                | 15.0.20    | Enabled                             | GPLv3+      |
| outroutemsg          | 15.0.9     | Enabled                             | GPLv3+      |
| paging               | 15.0.4.23  | Enabled                             | GPLv3+      |
| pagingpro            | 15.0.1.20  | Enabled                             | Commercial  |
| parking              | 15.0.15.1  | Enabled                             | GPLv3+      |
| parkpro              | 15.0.12.12 | Enabled                             | Commercial  |
| pbdirectory          | 2.11.0.6   | Enabled                             | GPLv3+      |
| phonebook            | 15.0.11    | Enabled                             | GPLv3+      |
| phpinfo              | 13.0.2     | Enabled                             | GPLv2+      |
| pinsets              | 15.0.1.10  | Enabled                             | GPLv3+      |
| pinsetspro           | 15.0.3     | Enabled                             | Commercial  |
| pm2                  | 15.0.3.8   | Enabled                             | AGPLv3+     |
| pms                  | 15.0.2.47  | Enabled                             | Commercial  |
| presencestate        | 15.0.9     | Enabled                             | GPLv3+      |
| printextensions      | 13.0.3.2   | Enabled                             | GPLv3+      |
| queuemetrics         | 2.11.0.3   | Enabled                             | GPLv3+      |
| queueprio            | 15.0.10    | Enabled                             | GPLv3+      |
| queues               | 15.0.20    | Enabled                             | GPLv2+      |
| queuestats           | 15.0.3.27  | Enabled                             | Commercial  |
| qxact_reports        | 15.0.3.23  | Enabled                             | Commercial  |
| recording_report     | 15.0.4.29  | Enabled                             | Commercial  |
| recordings           | 15.0.3.13  | Enabled                             | GPLv3+      |
| restapi              | 13.0.21.2  | Enabled                             | AGPLv3      |
| restapps             | 15.0.19.7  | Enabled                             | Commercial  |
| ringgroups           | 15.0.11.8  | Enabled                             | GPLv3+      |
| sangomacrm           | 15.0.14.46 | Enabled                             | Commercial  |
| setcid               | 15.0.8     | Enabled                             | GPLv3+      |
| sipsettings          | 15.0.6.27  | Enabled                             | AGPLv3+     |
| sipstation           | 15.0.5.8   | Enabled                             | Commercial  |
| sms                  | 15.0.10    | Enabled                             | Commercial  |
| soundlang            | 15.0.5.7   | Enabled                             | GPLv3+      |
| speeddial            | 2.11.0.4   | Enabled                             | GPLv3+      |
| superfecta           | 15.0.2.23  | Enabled                             | GPLv2+      |
| sysadmin             | 15.0.16.4  | Enabled                             | Commercial  |
| timeconditions       | 15.0.15.2  | Enabled                             | GPLv3+      |
| tts                  | 15.0.9     | Enabled                             | GPLv3+      |
| ttsengines           | 15.0.4.6   | Enabled                             | AGPLv3      |
| ucp                  | 15.0.6.17  | Enabled                             | AGPLv3+     |
| userman              | 15.0.28    | Enabled                             | AGPLv3+     |
| vega                 | 15.0.9     | Enabled                             | Commercial+ |
| versionupgrade       | 14.0.11    | Disabled; Pending upgrade to 14.0.5 | Commercial  |
| vmblast              | 15.0.11.4  | Enabled                             | GPLv3+      |
| vmnotify             | 15.0.11    | Enabled                             | Commercial  |
| voicemail            | 15.0.18.15 | Enabled                             | GPLv3+      |
| voicemail_report     | 15.0.5     | Enabled                             | Commercial  |
| vqplus               | 15.0.7.15  | Enabled                             | Commercial  |
| weakpasswords        | 13.0.2     | Enabled                             | GPLv3+      |
| webcallback          | 15.0.6.2   | Enabled                             | Commercial  |
| webrtc               | 15.0.8     | Enabled                             | GPLv3+      |
| xmpp                 | 15.0.6.4   | Enabled                             | AGPLv3      |
| zulu                 | 15.0.58.3  | Enabled                             | Commercial  |
+----------------------+------------+-------------------------------------+-------------+

Thanks
Steve


(Lorne Gaetz) #5

Not sure what’s happening here, when you upgraded to 15, the 14->15 upgrade module should have been removed. It’s doing nothing for you now, so remove it:

fwconsole ma delete versionupgrade

(Scrandall) #6

Thanks!!! That solved the issue.

Steve


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.