EPM - Base file edit error

Error on Save and Rebuild:

EPM 13.0.109

How do your expect us to help you when you give no versions on anything.

1 Like

I tend to forget it is not an ongoing dialog. Sorry. See above.

That’s doesn’t help. We need your FreePBX version and EPM version.

version is EPM 13.0.109.

Works for me using EPM 13.0.112. Not particularly meaningful unless, by pure coincidence, my test method happens to match the steps required to trigger the issue.

I would update to latest before ever even posting here.

My system is not offering an up date for EPM.
I am having other issues which I have not pinned down like phones displaying “FILE NOT FOUND” at the end of restart and config changes not showing up on phones. I am wondering if this has anything to do with my duplicating to an already existing template name, expecting it to ask if I wanted to replace it. I ended up with two copies of the same named template and when I tried to delete one, it deleted both. That happened about the time I began having strange issues with EPM.
Just a thought.

If you are not seeing updates that means your maint has expired on EPM and why you cant get uprades

Really, and how do I tell? There is nothing informative in MODULE ADMIN. I just renewed and was under the impression I was good for awhile.
This brings up a sore point. I have never been able to get EPM running, for a number of reasons, since I purchased it a couple of years ago. As a result, I have paid the license fee, the later imposed renewal fee, and additional renewal to try to get it running previously. I was told that my latest renewal this month would only be good for a couple of months due to having to cover back to previous renewals. So, for a module I have never used, I am up to some where over $150 soon to be $175. You can imagine that I am not a happy camper as I struggle with getting it to work for the first time what for ever reason.
All this due to the message that OSS is unsupported so I should not be cheep and use EPM. OSS actually worked fine, better in some ways with my Aastras, but I was worried I need to future proof my PBX by using the supported endpoint manager. Ouch!

Not sure about the term “Free”

Go to Admin->Module Admin
Make sure “commercial” is selected on top
Click "check on line"
Expand the “Endpoint Manager” and see what it says.

“This Modules Free Upgrade period is ending.
Your licence for Free upgrades to this module will expire on 2017-12-01 04:19:12 UTC.”

I have tried to force download and Install but it ended in an error.

open a commercial support ticket at https://support.sangoma.com and they can look in to the update issue.

Thanks, In the mean time, am restoring the image saved following installation of v13 32-bit distro.

Endpoint 110, 111 and 112 are EDGE releases only. 109 is the latest stable reload.

That explains the update question, thanks. I restored back to just after I installed the fresh copy of the v13 distro. I am still wrestling with problems updating the Aastra phones which seem to require resetting to factory defaults to load correctly. I don’t remember OSS having this much difficulty updating when the template is modified. Also, I have seen the phones restart when rebuild and update is selected but that seems to not be happening at this point. At the moment, I am not wanting to experiment much until I can make a new whole image backup as I am afraid of breaking EPM again.
As an Aastra shop, I wish I could say EPM is wonderful but at the moment I am really unsure what the future with it looks like. More Aastra EPM helpful documentation examples would be great. The Sangoma based examples are very different.

All EPM does is write out a config. Nothing more. If the phone doesn’t take it something is wrong with your phones or setup. If a factory restore gets the phone to take the config but a reboot doesn’t that clearly shows it’s something on your end.

Possiby, but as I said, I don’t remember it being this difficult to load modified configs under OSS. Might be worth reviewing how the Aastras are supposed to be working as just saying it is something on my end doesn’t help me understand what I should expect. All I have is EPM and Aastra phones and little info on how EPM expects to be setup for them so I can’t tell if it is working as expected.

An issue here may be the association between the oss endpoint manager and endpoint. They serve the same general purpose but that is about it. The commercial endpoint manager took a completely different approach to the task. The modules share ZERO code and were developed independent of each other. So you can’t look at the commercial EPM and say well this is what I did over there.

May I suggest the EPM wiki. It has an insane amount of information.