Endpoint manager not installing phones

Endpoint manager 2.10.x

When I go to “Endpoint Configuration” and check for updates, it lists all of the supported phones with an “Install” button next to each. When pressing the “install” button, nothing happens. I’m reading everywhere that you simply hit Install and everything works. I’m not sure why this is occurring. Any ideas?

You aren’t suppose to use endpoint manager 2.10 in anything less than FreePBX 2.10

Where did you even find 2.10!!

You have to use Endpoint Manager 2.9. Sorry this is not clear. It is a freepbx thing that I am working on fixing (soon) but if you used FreePBX 2.10 you would see why Endpoint Manager 2.10 only works in FreePBX 2.10

As I said please use Endpoint Manager 2.9 until further notice. (http://www.the159.com/endpointman/endpointman-

There is no EASY button in VoIP. There is a little more work than just hitting install and it works.

When you go to “Endpoint Configuration” and check for updates, EPM goes out and looks for updates for packages for the models of phones it supports. You can then install the basic templates and firmware for the models of phones you will be using.

You then need to go to “Advanced configuration” and make sure the IP address of the phone server is correct.

You also need to make sure that your DHCP server is sending out the correct boot parameters for your phones so when the phones boot and request a DHCP address then also get the boot server which is your phone server.

When you add extensions to the system you can enter the MAC address of the phone and fill out the remaining fields that need to have data entered in them.

“EPM goes out and looks for updates for packages for the models of phones it supports. You can then install the basic templates and firmware for the models of phones you will be using.”

But I’m not even getting this far. It’s having trouble, I suppose, finding those updates. As soon as I click “Install”, it does nothing. Also, when I check for updates, it finds the supported phones, but no package information at all.

I just did a check for updates on a server. I am running Polycom phones. When I hit check for updates I get a little popup that says loading and then the following appears next to the Polycom section in the endpoint Configuration Manager.

Polycom (Package Last Modified [10-26-11 at 10:08am]) Check Online
New Package Modified [10-30-11 at 11:56pm]

I wish I was getting anything like that. :slight_smile: I’m not sure what to do now. I’ve tried several different versions of Endpoint Manager. I never get the popup that says loading. I just get a screen staring back at me. :slight_smile:

okay. so I’ve removed, but as before, when I load, the 4 options for Endpoint do not show up on the left side like they do with 2.10.x is installed. This is why I assumed 2.10 would somehow work for me, because 2.9 wasn’t even giving me the options to configure. I rebooted, and still the options aren’t showing up. Is there something else I should be doing when 2.9.x is loaded so that the options show up to configure the endpoints?

I did read that with my, only use 2.9.x, but like I said, I was perplexed that 2.10.x gave me the options to configure where 2.9.x did not.


BTW, I found 2.10.x here: http://www.the159.com/endpointman/

wow. I found endpoint in a different location, under tools. I could have sworn that it wasn’t there before. Anyhow, I’m now on my way. Thank you for the help!!!

So I now have a GPX2000 that is working correctly, as well as a couple of Aastra phones. I have installed the firmware via EPM, and my Polycom 6000 is not registering. Having similar issue with Cisco 7941, but Cisco 7941 in EPM is not even giving me the option to “Install Firmware”.

We have option 66 and 150 on our DHCP server. Just not sure why some of them are smooth sailing, and others aren’t registering.

Further, the GS and Aastra’s that I got to work (line and name label and outbound/inbound calling) show as not registered (RED ball) in EPM Device List. Thought that was odd as well.


I had to manually add tftp on polycom, now it works. Still showing RED on EPM though.

what does ‘sip show peers’ tell you?

5031/5031 D N A 5 060 OK (2 ms)

I am also having some issues with EPM and this seems like the place to go to get help (let me know if this is too far off topic and I’ll start a new thread).

I have an Ubuntu 10.04LTS server with Asterisk v1.8.7 and FreePBX v2.9.0. I originally installed EPM via the module admin but couldn’t get it to work and then removed it and downloaded from the link above and installed it. Trouble is, when I click on Get Updates, I get a loading screen with a progress ‘swirlie’ but it ultimately times out and sends me to theprovisioner.net to manually download the files. Not a big deal but, when I go to the page and click on the .tgz files that I need (master and polycom), it tells me that “This topic does not exist yet” (does that for all of them). Any advice?

I don’t currently support uploading the files manually at this time because of site backend changes that are on-going.

The provisioner.net site is not down. All updates are obtained from freepbx.org anyways. This leads me to believe that you actually are unable to even use module admin to update FreePBX. The 2.9.3.x release actually made it easier to get automatic updates which is strange why you can’t. You should really fix your DNS server on your machine. Trying things like ping google.com or ping mirror.freepbx.org would probably fail for you. You should fix these problems first and formost. Then restart the webserver.

I’m having similer issues, but before I ask a question I want to be sure I have gone through all the configuration I should have.

Are there any wiki’s, how to’s etc for Endpoint Manager? I have a few cisco 79xx that are dying to be turned in to SIP phones.

No there is no documentation. What is your issue?

Ok, After some fiddling I realizes the problem was my tftp server was not serving.

I’ve moved the file to another box with a tftp server I know how to view the logs of.

I think the issue maybe the firmware files. The OS79XX.TXT file produced by End point Manager contains P0S3-8-12-00, which I believe is the correct syntax as it has the S standing for SIP.

I’ve down losaded the firmware files from
but the OS79XX.TXT contains P003-8-12-00. The files from the site are:

should I use the End Point 0S79XX.txt the phone requests P0S-8-12-00.sbn it fails as the file starts with P003 and not P0S3, If I use the 0S79XX file with the P003-8-12-00 it either ignores it or says it an invalid phone load.

If I rename P003-8-12-00.sbn to have a P0S3 start it varifies thr file and trys to lod it but then fails with a file auth fail, which I think is because i’ve changed the name of the file.

The bootload version is PC0303010100 and App version is P00305000600

I would get the files from Cisco but I don’t have CCO login.

I hope this make sence.

First, I deleted the link to the pirated software. You should not have to do any of these theatrics to get to get this to work.

The OS79xx.TXT should be included with the software load.

Additionally I know it is on the XML and I think it is in the older flat files the software load is explicitly defined.

Lastly, it is important to know how the tftp server works, if you edit the follow line in /etc/xinetd.d/tftp

change the following line to read:

server_args             = -v -s /tftpboot

the -v turns on verbosity.

Restart the service ‘service xinetd restart’

Now you will see lines like this in your /var/log/messages file

Nov  4 19:29:51 maieast in.tftpd[15396]: RRQ from filename aastra.cfg

Hope this helps.

I didn’t realise it was pirated.

I’ll have a go

I’ve got the Cisco 7940 working using a seperate tftp server on my PC the issue was that the versions on the phone were so old that it didn’t know how to be upgraded. I did a intermediate upgrade to Dip 6.3 them up to 8.12.

The problem I have now is that the tftp server is not working on the on the FreePBX box. I did what you suggested above and there are no refrances in the messages file to tftp. Does the End Point manager install and start the tftp server or should that be done seprately.