Endpoint manager error after choosing save and apply to phones


#1

FreePBX 15.0.17.12
Current Asterisk Version: 13.38.1

This morning a client reported none of their phones were connected. These are all Digium D62 and D65 phones configured with EPM. Selecting “use old server” was successful in brining the phones up and connecting to the PBX.

I did a factory reset on a phone they weren’t using currently and it will not come up. Phone displays “Error handshaking with proxy. Choose a new …”

I’ve updated endpoint manager to the latest edge version. still no good. All of the extension in EPM are showing as yellow and needing an update. If I go into the template for digium phones and select. “Save, Rebuild Configs and update phones” it crashes.

/var/www/html/admin/modules/endpoint/functions.inc/functions_digium.php

Arguments

1. "DOMDocument::loadXML(): Unescaped ‘&;lt;’ not allowed in attributes values in Entity, line: 114"

Module updates were done over the weekend but no changes to the template were made.
I can post more of the data from the error screen if necessary.


#2

Update: Any submit on any page generates the error.


#3

DHCP Option 66 data that phones are getting: sip:proxy@10.1.96.23:5060

These phones are using chan_sip protocol.

chan_sip port is 5160. Tried using both in the option 66 setting, still no dice.


(Lorne Gaetz) #4

I recommend you open a support ticket so we can properly evaluate what’s going on here.
https://wiki.sangoma.com/display/FPAS/How+To+Open+A+Support+Ticket


#5

already did.


#6

for some reason login for provisioning isn’t working. I try to go to the provisioning address in a web browser using the username/password set in system admin > provisioning protocols. the ‘xxx’ and 'yyyyyy" below are purposely changed for obvious reasons but I’ve double checked the username and password from provisioning protocols…

Example: https://xxxxxx:yyyyyyyyyyyyy@10.1.96.23:1443

Forbidden

You don’t have permission to access /.noindex.html on this server.


(Lorne Gaetz) #7

That’s not an authentication error, and it’s normal. Request an actual file as part of the URL, i.e.

https://xxxxxx:yyyyyyyyyyyyy@10.1.96.23:1443/aastra.cfg

You probably need the cert fqdn for https to work.


#8

in the past I’ve seen where it will actually list the files…

Are you saying that the IP address won’t work? I’ve tried with both http and https. I can understand where https won’t work without the certified FQDN, that makes sense now that you say it.

you’re link example worked (with http). however if I substitute the macaddr.cfg that the phone is looking for it fails

http://10.1.96.23:84/000FD30EB296.cfg

I can see the phone trying to access this file…


(Lorne Gaetz) #9

If you’re using DPMA for your phones, then they are not provisioned using http, they provision using SIP Message packets, which is what you Option 66 string shows.


#10

ok, so yes, I am using DPMA via EPM. (Sorry first time using EPM with Digium phones instead of the Digium phones module)

so my option 66 should look like this?

sip:proxy@10.1.96.23


(Lorne Gaetz) #11

Supported option 66 string format for DPMA is

sip:proxy@ip_address:port

where the port is the DPMA port specified in EPM DPMA Settings.

Probably not your issue, but you’re still on Asterisk version 13 which is EOL. Recommend upgrading to 16:
https://wiki.freepbx.org/display/PPS/Changing+Major+Asterisk+Versions+on+the+Fly


#12

ok, updated to 16.

configed option 66 as: sip:proxy@10.1.96.23:5060

error on phone now is: error fetching config from proxy.


#13

under EPM > Global settings > DPMA Management

I click on “Migrate to new DPMA” and get error:

#### Please wait while Migration process are performed

Checking Asterisk Digium phone module rpm…
Already Installed with required version.
Updating the database tables for setup new DPMA…
Successfully updated.
Generating new DPMA config files…
DPMA files generated successfully.
{“error”:{“type”:“Whoops\Exception\ErrorException”,“message”:“DOMDocument::loadXML(): Unescaped ‘<’ not allowed in attributes values in Entity, line: 114”,“file”:"/var/www/html/admin/modules/endpoint/functions.inc/functions_digium.php",“line”:456}}

and the button doesn’t go away so I assume it hasn’t been applied


(Kapil Gupta) #14

Hi @ashcortech If you have already raised the support ticket then please PM me the ticket# so we can work through support ticketing system.

thanks.
Kapil


#15

Kapil,

I entered a ticket for the error at the top of the ticket but not for the “Migrate to DPMA” errror yet.

One thing that occurred to me. these phones are using chan_sip which is using port 5160. DPMA Managment specifies port 5060 (which in Freepbx is not assigned to chan_pjsip).

If I change the DPMA Management setting to port 5160 and the Option 66 accordingly, would this solve this issue? or is the port in DPMA Management in separate from the chan_sip port?


(Kapil Gupta) #16

Hi @ashcortech DPMA allows phones to use the SIP port to communicate with asterisk to fetch the configuration so depends on your situation, you can use the port.

also just fyi - https://wiki.freepbx.org/display/FPG/EPM-DPMA+for+Digium+Phones#EPM-DPMAforDigiumPhones-PhoneConfiguration-Option66

thanks
Kapil


#17

Kapil,

Sorry, that didn’t really answer my port question. Let me rephrase:

Do the port settings for, DPMA Managment, Chan_Sip and the Option 66 have to all be the same to provision phones through EPM using DPMA?


(Lorne Gaetz) #18

The DPMA port is independent of whatever SIP port bindings you are using. Your provisioning string must use the DPMA port.


#19

Thanks for confirming Lorne!


#20

Still can’t upgrade to the new DPMA module. Created an issue https://issues.freepbx.org/browse/FREEPBX-22192