Endpoint 'anonymous' has no configured AORs`

Followed the FreePBX tutorial from Crosstalk. I’m currently on " FreePBX 101 v14 Part 6 - Manual Phone Setup", easily searchable through youtube.

He has everyone change the ports for chan_sip and chan_pjsip back to their older port designations, which I did. Now I get this when failing to register with X-Lite for Windows:

[2019-01-13 01:33:05] WARNING[24993] res_pjsip_registrar.c: Endpoint 'anonymous' has no configured AORs

After looking in the Asterisk logs, here are no further supporting log entries. The above is all that shows when I try to register my softphone.

I found one other forum topic but it has nothing to do with my issue aside from the actual error itself. The guy was being flooded with bots, but my system is behind a router and it’s a first time setup so nothing is pounding my server.

I’d love to have this answered properly so people in the future can benefit. Happy to go through any configuration problems that might exist but I followed the videos pretty precisely. I’m also using the Freepbx premade iso, if it helps.

When you change bind ports or other network settings, you must restart (not just reload) Asterisk. Do an
fwconsole restart
or reboot the whole server.

If that’s not your issue, please post:

Are you trying to use pjsip or chan_sip with your X-Lite extension? (It is contacting pjsip, which seems to not recognize the extension number.)

What port is X-Lite configured to connect to? For example, setting Domain to 192.168.1.123:5160 would connect to port 5160. If the port number is not specified, 5060 will be used.

What is the value of Bind Port for chan_sip?

What is the value of Port to Listen On for pjsip?

From the pjsip.conf.sample file (.samples are where the examples and setting details are outlined.)

; Anonymous Calls
;
; By default anonymous inbound calls via PJSIP are not allowed. If you want to
; route anonymous calls you’ll need to define an endpoint named “anonymous”.
; res_pjsip_endpoint_identifier_anonymous.so handles that functionality so it
; must be loaded. It is not recommended to accept anonymous calls.

There must be an endpoint defined as [anonymous] in order for calls to be accepted on PJSIP from anonymous callers. That endpoint then must define AORs to be used, if an endpoint doesn’t have any defined AORs then that will throw the error.

When you have “Allow SIP Guests” set to Yes then FreePBX will do just that, it will create an [anonymous] endpoint so PJSIP will just accept random calls. You end up with this and you’ll notice no AORs are defined (AORs are where contacts and thus where calls can be sent are defined)

[anonymous]
type=endpoint
context=from-sip-external
allow=all

So is there are reason that you have “Allow SIP Guests” on? Because that just means that both Chan_SIP and Chan_PJSIP are allowing any calls to be accepted regardless of there being a valid endpoint/peer or not. I would suggest setting Allow SIP Guests to No and this will go away.

You can learn more about PJSIP, its config sections and settings here: https://github.com/asterisk/asterisk/blob/master/configs/samples/pjsip.conf.sample

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.