DTMF issues in Asterisk releases?

The main problem with this thread is the OP mixed the DTMF issue and jumped on not being able to pick up calls.

Now the OP answered the question that the phones are all one net however he never answered these questions:

I am guilty as charged of using any chance to further my “just say no to distro’s” platform (in most cases).

On a lighter note I still think that damn fish is going to have something to do with the ultimate solution.

I have tried this with and without a nat with all the equipment and softphones on the same subnet or “side” of the nat.

My steps are exactly like the ones listed by cosmicwombat, in the same order.

The base of Mysql, PHP5 and Apache are added during the OS install:

The prereqs I used with Centos are:

yum install e2fsprogs-devel keyutils-libs-devel krb5-devel libogg libselinux-devel libsepol-devel libxml2-devel libtiff-devel gmp php-pear php-pear-DB php-gd php-mysql php-pdo kernel-devel ncurses-devel audiofile-devel libogg-devel openssl-devel mysql-devel zlib-devel perl-DateManip sendmail-cf sox

Wtih Ubuntu:

apt-get -y install linux-headers-uname -r --force-yes
apt-get -y install openssh-server make bison flex g++ gcc php5-curl php5-cli php5-mysql php-pear php-db php5-gd curl sox libncurses5-dev libssl-dev libmysqlclient15-dev mpg123

< Insert wombat’s instructions here. >

I will admit I don’t understand the DTMF thing so well. I saw an article on another site or forum that mentioned it so I had to ask. On my Grandstream phones the settings are “in audio” and “via RTP”.

I also thought codec issues might be a problem so I have tested with and without g729.

I don’t know how this turned into a distro debate. In the initial post I clearly stated that I had tried with CENTOS and Ubuntu. I didn’t post this to make a statment about Ubuntu. I haven’t done much with 1.6 and I just wanted some help. I have done at least 100 installs with 1.4 and never had this problem.

Sorry to create such a stir.

I do NOT set phones inside the NAT to “nat=yes”. My 1st client had 30 remote phones outside his NAT, and 20 inside. I understand that setting and learned all the ways you could go wrong with a NAT from him setting up new extensions and phones when I wasn’t available.

I think I am also clear on the NAT settings for Freepbx. I have done this with both static and dynamic IPs on the outside.

I’ll be the 1st to admit this is probably a stupid, little mistake I am making somewhere in the install of 1.6x but it’s hard to swallow that when I can do the exact same install with no errors or issues on 1.4x.

Did you try an IAX softphone?

Can you dial *60 from inside the network?

Since you’re unwilling to consider the fish as a possible issue your next step is to break out wireshark and see what is happening.

I would grab a tcpdumb on the box running Asterisk and analyze it offline. You will need a hub or a switch that supports port mirroring (spanning in Cisco speak. Don’t forget to increase the packet capture “snarl” length or you will only grab headers and not payload.

Since you are in uncharted waters with regard to this issue you have to be willing to do a deep dive.

But I have not tried an IAX softphone. I have an IAX hard phone in the other room. I will get it set to use with the build I am doing now.

I don’t have access to a hub/switch with those “super powers” but I will ask around.

I have not tried *60. I will try it and report back.

Meantime I traded the Giant grass carp pic for a “largemouth” in honor of all the opinions this post has generated.

Thanks for your help SKO and others.

DTMF on my phones is via RTP (RFC2833).

But thanks for the input. I am just looking for a second pair of eyes on what would seem to be a very simple problem or fix.

Skyking’s quick DTMF class -

RFC2833 encodes the DTMF in the RTP stream, it is decoded at the other end. Inband simply digitizes the tones with all the other audio.

1 - DTMF method must match, don’t use auto
2 - RFC2833 or SIP INFO method (like 2833 but uses SIP messages to send DTMF data)
must be used on all but full bit rate CODEC’s

The DTMF issue has nothing to do with the can’t pick up the phone issue.

Any hub will work, or a managed switch with port mirroring. I also suggest you take a quick network 101 refresher.

Lastly, I still see the same fish.

Maybe the 1.4x is a little more forgiving on the prereqs and maybe my prereqs work for 1.4x but not 1.6x.

SKO,…I did change the picture and it looks great. That’s 1 handsome man and 1 handsome fish.

Would you like a 101 lesson on browsers and “cache”?

Would you mind taking a look at the prereqs I install,… about 10 posts back?

Ok, so I didn’t refresh my cache. As far as judging male or fish attractiveness, that task I will defer.

I looked at what you installed. Asterisk doesn’t depend on anything to process calls. You are barking up the wrong tree.

Did you try the IAX thing yet? It’s a very important data point. Load Zoiper softphone it takes 5 minutes.

If you build Asterisk 1.4 on the same machine with no other changes does it run? Do you know how to build asterisk to another directory so you can have both versions on the same machine?

I have never been able to get any Asterisk 1.6 install to do anything on Freepbx if I did NOT “make samples”.

Without I get a loop where asterisk restarts with an error code “1” when I do ./start_asterisk start and can’t proceed with the install. If I install the “samples” it goes on but I still can’t answer an inbound call. BUT,…I wonder if something in the samples is hosing the whole config.

BTW SKO,…I can’t get my Hard IAX phone or Zoiper to register. I checked and double checked the settings I created for the IAX extension on Freepbx to make sure I didn’t make a type-O and bad match.

I have used “Zoiper” before with no problems on my working, Asterisk 1.4x machines.

You hinted that this could lead to an important clue SKO/Shaggy. What do you make of that?

I am definitely driving the “Mystery Machine”.

If it’s supposed to give me the current time.

FreePBX makes all the files needed to start. You should not have to make the samples. Let’s stay on one topic.

You need to be more precise *60 works where? On what phone and on what network?

I tried it with both of my hard sip phones that are on the same subnet as the PBX.

Ok and that same phone if you call it from the other phone and pick up the extension the phone you called from receives ringback?

It’s been that way since the beginning.

Someone mentioned checking in with my service provider. Here’s what they had to say:

May 10, 2010 08:20 AM : Customer service

Please add the following lines into your Callcentric trunk:


Additionally, within your Callcentric trunk please change “username=17772789999” to “defaultuser=17772789999”. After doing so please restart Asterisk.

I did that,…still no worky. I wrote back and this was their response.

May 10, 2010 02:03 PM : Customer service

We have reviewed your calling history, and on a few occasions we do see that a few of of your incoming calls are dropping specifically due to a “media timeout” which basically means that our system did not detect any audio being transmitted in either direction (our system drops these types of calls automatically, as a way to drop “rouge” calls). If you would, within your PBX’s configurations, please try adding the line “session-timers=refuse” to your sip.conf file (or if you are using freePBX in conduction with your PBX, your sip_general_custom.conf file). Once you have included the line above, you may need to restart the entire Asterisk service in order for the changes to take into effect.

I did a very careful walk through of my script manually and added the “session-timers=refuse” to sip_general_custom.conf.

Thanks for everyone’s input. Philippe’s suggestion that it might be a carrier issue never occurred to me since I have never had any issues with Callcentric. They have excellent support and I am sorry I didn’t call them sooner.

Again,…thanks everyone for putting up with me,



first off don’tput it in sip_general_additional.conf, it will get automatically removed.

If I’m not mistaken, this is a trunk specific setting so it may be better off there. If that is not the case, then it should go into sip_general_custom.conf (as they suggested) though if you are using the Asterisk SIP Settings module, you can define it in that module and not have to mess with the configuration file.

As far as the session-timers=refuse fix, there was a bug at one point in Asterisk that triggered this problem:


I don’t know if this is the same or not but was related and it was suppose to have gotten fixed. Here is another thread related to that bug:


anyhow - glad you got it fixed.

That is where I put. In my excitement I typed additional without thinking.

Thanks for the additional feedback about the possible bug.

mwilson - If you had noted that extension to extension calling worked fine we would have been able to get to a solution quicker than we did.

It is very important to provide all the facts.

I just upgraded my home system to 1.6x with what I learned from Callcentric. Both of their suggested updates ended up being necessary evils.

Step 1 --------------------------
May 10, 2010 08:20 AM : Customer service

Please add the following lines into your Callcentric trunk:


Additionally, within your Callcentric trunk please change “username=17772789999” to “defaultuser=1777278999”. After doing so please restart Asterisk.

Step 2 ---------------------------

Add session-timers=refuse to your sip configuration,… “Using the Asterisk SIP Settings module” (as per Phillipe), bottom of the page, “Other SIP settings”

Now my home system is running like a top under Ubuntu 10.4, Dahdi 2.3.0 complete and Asterisk 1.6.27. Touche to the Ubuntu bashers.

I appreciate your help and input Sky King, “Point Taken”, but I’ve made so many posts about this in so many places that I forgot to mention I could make outbound calls and ext to ext. I thought I had said it (inbound pickup) was the only thing I couldn’t do,… but I just reviewed the whole thread and see that I did NOT word it that way.

I mentioned the details of my OS/distro and the whole thread went off the rails. Apparently those people didn’t read the 1st entry of this post where I said I had also done the build with Centos 5.4.

Thanks again to all,