DTMF issues in Asterisk releases?

I am still having issues with Asterisk 1.6 installs. I never got any feedback on my previous post but I got a possible hint from a post with advice on upgrading.

The hint was that newer releases of Asterisk like 1.4.29 had issues with DTMF.

Could this be the reason I can never answer an inbound call after any upgrade or installation of Asterisk on, Centos 5.4, Debian Lemmy or Ubuntu 9.10,…with Freeobx 2.7.0??

I’ve been doing builds on Ubuntu for over a year without any problems.

I can do the exact same build with either distro and Asterisk 1.4x and it’s flawless. If I switch to 1.6x and I’ve tried, and

Yes, SkyKing all the equipment is on the same subnet.

I have done the same installs on 2 other machines. One is a very generic, late model Dell P4 the other is on an ASUS mobo with an Atom 330.

I am not “locked into the fit-pc2.” I just really like it. Have you seen the “Hexapod” videos? It’s a little, green marketing machine.

I have done at least 3 failed 1.6x installs on each of the above hardware platforms. And yes,…I tried Centos at least twice on the Dell and ASUS PCs.

So,…I really don’t think this has anything to do with my choice of distros or hardware.

I’m not trying to install Asterisk on Windows Vista, but if I was, I’m pretty sure I would still have the same problem installing Asterisk 1.6x as opposed to 1.4.

Does anyone see any problems in the Centos 5 installation recipe posted here? I followed it to the letter (except Asterisk version) on my Centos 5 Asterisk 1.6 installs so there must be a flaw in those instructions or a problem with Asterisk, or

I did another clean install with Ubuntu 9.10 and Asterisk

I got the same results. I can’t answer an inbound call. I pick up the phone and it keeps ringing leaving a blank voicemail.

Scratch the DTMF theory,…I guess.

I can’t comment on your issues on Ubuntu and the mainstream of Asterisk is on Centos. I use Centos 5.4. Asterisk and FreePBX 2.7 with no issues.

What kind of phones are you using?

That aside, why not get a fully integrated ISO like PBX-in-a-Flash and install that? Its all there for you without all the manual issues you face doing it by scratch.

Check out nerdvittles.com for some of the latest gee-whiz stuff.

I have my own recipe that creates a firewall-router, the PBX and installs webmin to make some of the final config chores a lot easier. It’s flawless until I use 1.6 instead of 1.4.

The phones are Grandstream GXP20xx.

I also used Centos 5.4 in one of my many iterations of the 1.6x install.

I am developing my own small form factor, “green”, Asterisk appliance for resale. One of the smaller boxes, I really like won’t run anything but Ubuntu due to driver issues.

I couldn’t find anything on nerdvittles.com about differences in the install procedure for Asterisk 1.4x and 1.6x.

But thanks anyway.

I need some clues!

Does PBX-in-a-Flash have some magic, update button to keep you on the latest release of Asterisk or is there an ISO out there with the latest version?

I’ve never tried PBX-in-a-Flash and now I’m curious.

PBX-in-a-flash comes with scripts which apply fixes and allow you to update within the release of Asterisk (get latest 1.4 if you installed 1.4 or get latest 1.6 if you installed 1.6. Also, check out www.nerdvittles.com for the latest PBX-in-a-Flash, “The Incredible PBX”.

PBX-in-a-Flash has various flavors that run on the Intel Atom green machines.

Do you research on PIAF, Trixbox and Elastix for starters to see which you like best. There is absolutely no reason to roll your own where you might be missing a vital library or a required part of the OS.

I have used PBX-In-A-Flash for almost 2 years. I started with Asterisk 1.2 and now use 1.6 with Freepbx 2.7. I think this is the most used configuration right now. Freepbx is very good as you know, and PIAF just integrates everything. They don’t roll out the updates until they have been tested, but that is done rather quickly. Once an update is released by Asterisk or Freepbx, the PIAF update is usually released within 2 days. With so many components having to work together it is just not worth the time to do it yourself. Plus, there is no advantage to it. With the PIAF and Freepbx forums you can usually find the answer to any questions, or if not, someone is available to help. By the way, I use GXP2000’s and they work great.



On the other hand integrators should role their own. To be reliant on a distribution and their repository is asking for trouble. For an integrator to truly add value they must maintain their own install scripts and vetting process for releases. It’s the only way to provide a meaningful SLA to the customer.

I have to roll my own and the systems I’ve been building with Ubuntu 9x and Asterisk 1.4x were nice tight joints. The whole process took about 25 minutes and I thought it was perfect until these recent problems with 1.6x.

I’m just trying to figure out what the difference is and educate myself. I won’t learn anything if I use someone else’s automated recipe.

Problem is,… I got lot’s of input here but didn’t get any clues about what the problem/difference would be.

As I stated earlier my install/script is based on the Centos 5.1 install posted here with changes made to handle the differences in LAMP on Ubuntu and use dahdi instead os Zaptel. I got the input on Ubu from the AsteriskOnUbuntu.sh I found. My current script even installs Webmin, just like PIAF.

It works perfectly if I run it with Asterisk 1.4.x. So I am just trying to figure out why it doesn’t work with Asterisk 1.6.x.

The fit-pc2 I am using in recent builds won’t run on anything but Ubuntu,…if I want support from the manufacturer. I also need the ext4 file system.

So Centos really isn’t an option.

I need Asterisk 1.6x for T38 support and hopefully multiple parking lots if I ever figure that out.

I am confused again, the pickup/ring problem. Do you have the issue if the phone is on the same LAN as the server?

mwilson, why are you locked into this “fit-pc2” and ubuntu ?

1st of all, I am not bashing Ubuntu ( or Debian ) for that matter. It is simply this… You seem to be asking what is the difference between an Asterisk install on CentOS vs. Ubuntu 9.x.

Well, apparently you are having trouble with dtmf and possibly call supervision using Ubuntu. Whereas if you were using CentOS, perhaps you would not have this problem. I know that sounds smug and seemingly ignorant. On the other hand, every major Asterisk/FreePBX distro uses CentOS and therefor the critical mass of users are there.

I see a lot of people try going down the “something other than CentOS” and Asterisk road beating themselves up over issues like you are having. My advise is to go with the flow a bit and see where that gets you.

I’ll even offer up a reverse scenario… I can never get the Nessus scanner to run well on anything but Ubuntu server. I prefer CentOS over Ubuntu, but I am not about to waste time when the solution is to go just slightly outside my comfort zone and use what works. I feel it is the same with Asterisk and CentOS.

All I can say is our Centos 5.4 machines with FreePBX 2.7 and Asterisk work. I’ve done it on an Intel Celeron Dell system, an Intel Pentium Dual Core Dell SC420, an Acer Revo Intel Atom machine and an old Pentium 3 Gateway machine. It works on all of those. Again, I’m useing the PBX-in-a-Flash distro for all.

I don’t have DTMF issues with Grandstream phones, Aastra phones, Avaya phones or Cisco phones. I use them locally and remotely through firewalls and NAT.

So if there is a difference in the Asterisk distro causing this on your particular home-rolled version, I can’t advise you what you need.

Perhaps you should load a functional distro on a test machine and look for differences between it and your own load. Perhaps libraries of a certain vintage or anything else strange that might become apparent to you in analysis.

I think if the problem was based on the install instructions on the FreePBX web site, there would be an uproar among other users.

You might also want to post all the particulars over on the Asterisk.org forums where you might find others more inclined to roll their own. Someone else may have also found the same issue with hardware or installs.

I just finished a cold build of CentOS 5.4, Asterisk and FreePBX 2.7 without any issues.

Do you have any kind of SIP Proxy or firewall software running on the build? What happens if you change the bind port.

If you answered this sorry for the repetition but have you tried a softphone (both IAX and SIP)?

m2wilson75, I am curious as to the actual build steps you take ?

Personally, I do the following after install deps are met ( and then using blah-current source downloads):

make all
make install

librpi (if needed)
make install

make menuselect ( I turn off skinny and mgcp)
make install

make menuselect ( I turn off OOH323)
make install

Then the last step is to install FreePBX.

Is your process like that ? And you receive no errors during install ?

What happens if you use a pkg install ? Does a current asterisk version exist and is it available via apt-get ?

It seems all of us are dancing around the answer you seek. I am still a little unclear about the “answer the call and it keeps ringing” part. That speaks of a network issue. Like sip_nat.conf is not configured correctly or the extension is set up as NAT=yes when it is not natted. Potentially a bad CAT5 cable or a problem with the switch could also be the cause of the phone not picking up the call.

DTMF issues could simply be a secondary symptom of anyone of those too.

Are you also trying a softphone to verify the fault ?

Hmm what an interesting scattered thread…

The original post is:

DTMF issues in Asterisk releases?

However, there is no description of what the specific issue is. Yes, I know there is a vague reference to “the other thread” and I’m sure if I go searching for “the other thread” (of which there is no link to it…) I would refresh my memory as to what is the issue.

However, it seems to have gone down a road to philosophical discussions of what distros to run or not. Now all that is fine and the forums are a great place to have such discussions. (Plus, for some reason, people really seem to like to have discussions about this subject, go figure :slight_smile:

However - what seems to be a bit wrong here is that the speculations are going somewhat wild. Someone says “I have a DTMF issue going to Asterisk 1.6” and it digresses into wild speculations that the distribution and/or Asterisk may be having problems with DTMF which really doesn’t make a whole lot of engineering sense when you step back and really think about it.

Even if there were remote possibilities that these may be related, some initial common sense might be in order. Now I realized that I didn’t got back and read the previous thread so maybe some of this is in that thread, but it isn’t here and I don’t know about you guys, but my memory is not that good nor my free time that liberal to go do the research and find and read the thread referred to at the beginning.

So … before going too far astray, I would think some questions might be in order such as:

  1. What are the dtmfmode settings for the two sides of the channels that are trying to talk?
  2. Has a SIP trace been examined (sip set debug on) between the two sides to see if a dtmfmode has been properly negotiated?
  3. Has a wireshark analysis been done of the attempted dialog to determine what if any dtmf signaling might be present?
  4. Has the dtmfmode been changed to something else to test/check if other modes are having issues?

And of course if this is inbound/outbound to some SIP provider, then who is the provider? Has this been discussed with them, and if so what is their feedback? Have they made any recent changes in their network? Do they have any configurations on their side that can/need to be adjusted depending on what version of Asterisk that is being run?

So … I didn’t really mean to break up the party (feel free to carry on), I just thought I’d ask some questions relevant to the original title of the post :slight_smile:

I am guilty of veering off course… Let me offer something useful I just noticed in my logs…

I just saw this in my log ( Asterisk / Snom 320 ) :

WARNING[14920] dsp.c: Inband DTMF is not supported on codec g729. Use RFC2833

Have you checked codecs ?