Dropping and reconnecting extensions on cloud server. Need help to get it solved

Hi All

I have been battling this issue for quite sometime and I thought I had it resolved but it came back. I really need some help to get this resolved.

Initially the issue was UNREACHABLE status, now it is UNKNOWN.

I got a cloud Freepbx server and 4 sites that are connecting to it with Cisco SPA508G phones. There are 31 extensions total.

I am assuming the issue is because of some lag in the system that’s casuing the extensions to drop and reconnect in a few seconds later.

When I started building the system I had just a few (approx 5) extensions that were connect to the server, they were stable and didn’t show any connections issues. Then I started to add more extensions and the UNREACHABLE status started to happen. I find a solution to that by making the register timeout on the Cisco phone set to 60 sec (Register expires field), it used to be 3600sec. So that worked well and everything was stable untill I added more and reached 30 extensions. The issue now is a random extension will disconnect, phone with have orange lights, and Asterisk will report the extension has status UKNOWN. Sometimes it will reconnect in a few seconds, but other time I need to replug the phone for it to connect.

Smart QOS is enabled on router.
NAT mode is set to YES on all SIP extensions.
Firewall on Freepbx server has ports open for 5061 and 10000-20000 (UDP)

I really would like to find a solution asap.

I would like to have the Freepbx server internally, but that is a problem becuase of the other sites that need to connect to it. I have VPN to all sites but not sure how well it will work if I bring the server inside. That is one possible fix but would like to see if I can fix the current problem instead.

Thank you for your help.

I am running version Asterisk 13.7.1

Looks like no one else had this experience, no experts to comment?

I have also found this page http://wiki.freepbx.org/display/FOP/Remote+Phone+Best+Practices+and+Limitations

it kind of explain the issue I am experiencing here under “Issues with having more than one phone at the same remote location”

What are the specs of said “server”. Do you have the resources to host freepbx for your extension count? (Sins it was designed for 5 extensions only)

So you are saying that Freepbx can handle 5 extensions only?

I am running following setup, I have only 29 extensions online.
10 GB HD

uptime : 12:19:18 up 16:47, 1 user, load average: 0.00, 0.00, 0.00

free -m:
             total       used       free     shared    buffers     cached
Mem:          1869       1534        335          0        238        247
-/+ buffers/cache:       1047        821
Swap:          767         23        744

VNo, i am saying your server was setup at first to handle 5 extensions,

Freepbx can handle as many as you want / trow at it

Edit: what speeds / bandwith are provided to the pbx?