Distorted Voicemail prompts on Mitel 5xxx Desksets

We are using mostly Mitel 5330, 5340, 5220 and 5212 desksets as we replaced a Mitel PBX with FreePBX. My issue is when calling voicemail, somewhere in between prompt (usualy a number, IE you have three… after the 3 all audio following is bad) recordings the audio will get very distorted. This does not happen on other brand phones (yealink is the other flavor I have a few around the office) or when dialing into voicemail from an outside line. I am running FreePBX with Asterisk version 13.18.0.

I have played with codecs with no luck and tried different system recordings. It seams like the EN-British does not cause the distortion, but I get the feeling it occurs when a voice recording exceeds a volume level? Has anyone else experienced this and been able to determined the cause/resolution?

Audio-Examples.tgz (302.8 KB)
Hi Jeff, I am having the same issue, so I figured I would add my system details to your post.


  • FreePBX with Asterisk 13.11.2


  • 5 x Mitel 5360
  • 1 x Mitel 5340e
  • 1 x Mitel 5320e
  • 1 x Mitel 5340
  • 2 x Grandstream GXP1405
  • 1 x Grandstream HT701 ATA

I am experiencing audio distortion (jitter-like) only within the voicemail system attendant, and only from the Mitel sets, which would suggest a configuration issue with them. The Grandstream sets are working fine across all codecs. I have changed preferred codec to G.722, G.711u, G.711a, G.729, but the issue persists with the Mitel sets. I have attached tgz’d audio examples from one of the Mitel sets and one of the Grandstream sets. If anyone has run into this issue before using Mitel sets in SIP mode with FreePBX, and would care to share how they fixed it, it would be much appreciated! Thanks in advance!

I did some further testing to prove it was a phone issue rather than from the PBX. I set up a monitor port on the switch a phone was on and ran wireshark while calling voicemail. I then played the audio captured from wireshark and verified it was clean, proving the phone itself is not reconstructing the audio correctly. I suspect the voicemail prompts are switching codecs during a call, but do not know enough to say for sure.

I was able to work around the issue by enabling g729 in the phone system, but left it at the bottom leaving it the least prefered codec (I had issues with sprint cell phones not detecting DTMF leaving salesmen unable to dial in to check voicemails) I then forced all Mitel desksets to use only g729 codec and now all audio is clear. I do not view this as a fix, but it corrected the issue. A proper fix would be nice if someone more knowledgeable than we is able to determine why this is happening.

I took captures of call examples to voicemail on the PBX from both a Mitel 5360 and a Grandstream 1405. I noticed the same issue is occurring to FreePBX conferences, and in my case, G.711u is being negotiated from both sets as my only options for codecs from the Mitel sets are G.722, G.711u, G.711a and G.729a; all of which are enabled. Both sets have G.722 set first and G.711u set second, however it doesn’t look like I can make the attendant use 722. I assume this isn’t supported. Through the duration of the call, the codec is not renegotiated. The audio stream in both captures is clean, again proving your point that the sets are receiving clean RTP from the PBX, but the set’s DSP seems to be processing the data, received in RTP, incorrectly. When you forced G.729, your audio was clean. I don’t have a G.729 license, and my only use for it would be observing different behavior here. I tried forcing G.711a, and had the same result as with 711u. Of course, without a 729 license, trying to force 729 from the PBX results in the PBX dropping the call during setup. So, from what I have gathered so far, the issue is with the Mitel set’s DSP processing of the G.711u/a audio received from the FreePBX host. I am out of the state at the moment, but when I return, I have one of the newer Mitel 6940 sets at the office that I can test with. Of course it is an entirely different platform than the older 53xx series.

You no longer need g729 licenses, search the forums here . . .

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.