Digium says EPM Pro causes phone browser issue

After configuring a group of D50 phones with EPM Pro, the web interface won’t load. I get an error:

“There was an error requesting or processing your phone settings. Try refreshing the page and if this problem persists please contact your system administrator”.

This message appears after I login to the web interface on the phone. It displays all the tabs, but this message is all that shows under the tabs. Here is what Digium Support is saying:

"I just got some feedback from Engineering about this situation. They advised that it’s strongly recommended to not use the web interface when the phone is provisioned with endpoint manager. This always leads to unexpected results like the behavior you are having.

I understand the situation. Unfortunately endpoint manager is not a Digium product but a Schmooze one as well as FreePBX. Digium does not offer support for these tools. In this particular case I would recommend contacting Schmooze to get support from them."

This is the second time I’ve had to play this game with support on Digium phones when using EPM Pro and the “Apps”. I really can’t afford to pay $160/hour for Schmooze support on this and I need the web interface to work. Any help?

All EPM does is provide config files to their phone. If the GUI is not working after it loads a config file would seem to be a bug in their phone or I guess a issue with our config file. I would send them a copy of the config file and ask them as if it was a problem with a config file the phone would not load it so I am really leaning that its a issue with their phone using XML configs.

Thank you for the reply, Tony. I’ve forwarded on to Digium support.

Also, I’ve found that the phones aren’t getting the firmware update I put in Slot 1 for them. And since I can’t get to the web GUI, I can’t update them that way either. I’m not sure if this is related or not, but it’s another data point.

This is our first implementation using EPM Pro and the Apps with Digium phones. I’d hoped the additional commercial software would smooth out the process, but instead it’s made it more complicated; this is the second time we’ve had to deal with Digium saying it’s EPM Pro and Schmooze saying it’s Digium.

@malcolmd Any feedback on this? Maybe someone with some insight could file a bug…

OK well I just took EPM and configured a brand new D70 no issues and can get into the GUI. So this has to be something either with your firmware or your phones. Not sure why you cant update firmware but you have provided no logs or details on what the issue for firmware is.

At this point I have notified Digium but its beyond our side and we have well over 2000 D70s using our EPM with Rest Apps already with no issues so we know that all works fine.

First bit of feedback is one of practicality. What is it that you’re trying to accomplish via the web interface?

When a phone is provisioned via a means other than the web interface, you’re precluding yourself from using the web interface to configure the phone. While it’s technically possible to still run the web interface, we disable it by default in Switchvox and DPMA installations - because the phone’s been provisioned otherwise and there’s no good that can come of mucking about with two configuration interfaces at the same time.

Perhaps some manipulation of the configuration was done via the web interface before the phone was configured via EPM. Or, perhaps some manipulation was done after the phone was configured via EPM. Either way, I’d suggest starting by factory defaulting the telephone. You can do that from a booted phone by pressing the check key (in the middle of the arrow keys), selecting “Advanced” from the menu, and then “Reset to Factory Defaults.”

I saw where you provided your configuration files to our Support team. They’re probably in the middle of investigating, but I took the liberty of loading it up myself. I had to change a few things, to make it point to my server instead, and I don’t have the apps running on my server (I’m just using an Asterisk box), but I can boot my phone and get straight into the phone’s web interface. I’ve used Chromium 35.0.1916.153, Chrome 38.0.2066.5, Firefox 28, Firefox 30, and Safari 7.0.4. That said, you really shouldn’t use the phone’s web config if you’re configuring the phone via another means. Badness will happen.

1 Like


Thanks for the feedback.

No prob; apologies for the delay; I saw the config come into the Support ticket and I wanted to give it the once-over.

In this case we have two remote phones. I provisioned them with EPM Pro (never accessed them via the web GUI). Once off-site they wouldn’t connect because they were looking for the internal IP of the FreePBX server to register. I needed to change that address and, with the phone off-site, I couldn’t except using the menu on the phone or the GUI.

If there’s a way to setup the initial config to allow this functionality I’m all ears and that’s great, but I still need to be able to change configs for remote phones that for one reason or another can’t connect to the server to pick up a new config file. For obvious reasons, resetting a remote phone to defaults isn’t a workable solution either.

I’m glad the GUI works for you. I tried two phones each with IE11 and FF30 and got the same result on all four tests.

And if the firmware update system in EPM Pro isn’t working, which it is not in our case, then flashing via the GUI is the only option of which I’m aware. It’s entirely possible this is a firmware problem, but as-is I have no way to get these phones to 1.05. Tony, I’m not sure what to provide other than I have 1.05 in Slot 1, and slot 1 selected in the phone template and the phones aren’t updating. I’ve just noticed that 1.06 is available. I’ve put that in slot 1 now and will test.

Happy to provide whatever you want, just give me specifics.

Ok now we are getting real facts here.

1- EPM provisioned the phone just fine. The issue is they are setup to reach the internal IP of the PBX which as a remote phone that does not work. Hence you should create a new tempatle that uses the external IP and have the phones pull that one.

2- Digium phones are not supported to allow changes from the GUI and config files or DPMA at the same time. This is not a EPM issue but a design of the Digium phones to protect them. Do not blame us for this.

3- The phone cant update firmware since its set to look to the internal IP how would it ever be able to grab updated firmware.

As Malcom from Digium said. Factory reset the phone. Nobody here or at Digium can re-create the issue and Malcom used your configs you gave him from EPM so its not a config issue.

Hi Tony-

To be clear, I didn’t blame EPM. Digium did. And as you mentioned, the web GUI should still work, instead of barfing up an error after login.

The phones on the local subnet are not pulling the firmware either. Not today, not ever. I’m not onsite at the moment, but I’ve just tried to reboot the two that are online and that function is not working. I’ll stop by the office this afternoon and do so.

I created a separate config template for the remote phone that I’m testing last week, set it to use that, and rebuilt its config. Since I’d previously used the phone menu to change the server IP to the public IP of the FreePBX server and enabled NAT for that template, it does register and make/receive calls, but again, no firmware update, and not rebootable. And extremely slow (10 minutes) to boot. It’s entirely possible I’ve setup the template incorrectly and for that I am willing to pay for some education time from support. As-is the external template is set to use a host name that resolves to the correct IP (internal or external) whether the device is on the local subnet or not (split DNS).

I’m sorry if you get the sense I was trying to hide info from you, that’s not my intent at all. I just want the system to be ready for the number port on Friday.

Again, very appreciative of the help today.

OK well at this point nothing more I can do for you. Digium has made it clear you can not use config files and GUI at the same time. It will break and barf things.

As far as firmware I just took a 2 phones updated firmware with no issues. I would start with watching your http logs and see if the phone is trying to grab a firmware.

Actually, what Digium said was:

“I just got some feedback from Engineering about this situation. They advised that it’s strongly recommended to not use the web interface when the phone is provisioned with endpoint manager. This always leads to unexpected results like the behavior you are having.”

That doesn’t suggest that EPM is at fault, it says that you shouldn’t mix and match configuration methods.

At this point, how can I tell what config file the phone is using if I can’t get into the web GUI at all? I understand your position of not mixing and matching config methods, but it would be extremely helpful to be able to at least review the config so I can see the settings and determine which file is in use.

And this:

“I understand the situation. Unfortunately endpoint manager is not a Digium product but a Schmooze one as well as FreePBX. Digium does not offer support for these tools. In this particular case I would recommend contacting Schmooze to get support from them.”

Which I read as, this is not our problem, contact Schmooze.

That was when you asked them about firmware not pulling had nothing to do with your post here in the beginning which was “Digium says EPM Pro causes phone browser issues”

Which you are misleading people by trying to pretend we are breaking the phone GUI which as Digium has already told you numerous times but you refuse to accept is that is how their phones work.

It looks like this may be diverging on to a bad direction.

We (FreePBX and Schmooze) enjoy a strong relationship with the Digium team. When situations like this come up we have folks like @malcolmd who we can come to and try to find a resolution. We do not generally care who’s problem it is if we can get it solved.

I think this may be seen as a finger pointing session. I have been doing support a long time and I know users hate when both sides point their fingers at each other and no one takes ownership.

In this case both sides have deferred ownership to the user because sometimes it is nobody’s fault but the person using the product(s).

That is not said to be a jerk though it probably comes across that way.

I understand the situation. Unfortunately endpoint manager is not a Digium product but a Schmooze one as well as FreePBX. Digium does not offer support for these tools. In this particular case I would recommend contacting Schmooze to get support from them.

This is an absolutely correct statement. It is not a pointing of the finger it is simply saying it is outside of their scope and their help cannot be provided. If you want help go to the folks who support it (US) for help.

From @tonyclewis and @malcolmd the consensus is it’s not us (Digium or FreePBX) but the manner of use. All phones should use a singular point of configuration.

##Choose your poison

  • Configure with EPM only (or other provisioning)
  • Configure through the WebUI
  • Multiple methods will cause bad JuJu

##Factory Reset
Once you have chosen your path factory reset the phone to go back to 0. Then provision by your chosen method. Not doing a factory reset will cause bad JuJu


  • Don’t do that
  • This is not a bug, defect or other problem
  • FreePBX/Schmmooze does NOT think this is a Digium problem
  • Digium Support does NOT think this is a FreePBX/Schmooze problem
  • We both agree there is no problem when used properly.
  • Proper use involves a single method of provisioning
  • A single point of provisioning involves doing a factory reset to get you back to a 0 point.

I am not intending, nor do I believe I am misleading people, Tony. I’m sorry you feel that way.

My ticket was open with Digium about the web browser issue. They clearly told me it’s not their problem and I had to go to Schmooze to get help with the behavior of their phone because EPM is in use. Their comments were about that. I don’t know why it’s broken. I know it is. I added the firmware update issue as an additional data point.

And at the same time, Digium is now telling me the GUI on their test phones work fine with the config file I sent, so the error I’m reporting is not expected behavior when using EPM.

As a consultant who’s been implementing FreePBX for several years now, I find this situation really frustrating. When things don’t work there has to be an option to get support. If it’s an error or lack of understanding on our part, I understand paying. But when it’s not, there has to be someone standing behind the product, especially the commercial modules. Several times now issues we’ve reported and had blamed on our infrastructure have just disappeared with updates. Including the REST API errors we had with this setup a couple months back.

I really don’t know how to behave when these things come up, as I’ve been criticized here for both suggesting there are bugs, and also for not filing bug reports, and also accused of hiding facts and misleading statements. Again, I’m sorry you and others feel this way, as it is NOT my intent, nor do I believe it’s the best way to solve problems.

Bottom line is that I just want the software and hardware to work for us and for our clients, and to be able to get effective support as needed. Being told to accept defective behavior as normal when Digium is telling me that the same config file on their test phones results in a functioning GUI is frustrating.

Far more than Schmooze, we need this relationship to work because when problems come up we don’t have anywhere else to turn, especially with commercial modules.

I get you feel there is a problem but Digium has clearly stated you can not use the GUI and XML configs at the same time. This is not a EPM issue or bug but how Digium phones work when using any provisioning setup. Please just accept this and move on. Done and over. Factory reset your phones and decide one way or another on how you want to provision your phones.

As far as firmware please start a fresh clean thread with logs showing what the phone does on boot when reaching out to http or ftp server you are using for configuration.