Digium Phone App Totally Broke


(Arthur) #1

Hello all, using PBX 15 and asterisk 16.20.

My asterisk servers keeps crashing when my digium d50 phones try to connect to my server.
I have no issues when i configure the phone directly from the web portal & I was just able to use the endpoint manager, but i’m loosing a lot of functionality i had using the Digium App.

I could setup bls dials for everyone from the phonebook - have the park functionality attached…
Are all these features configurable under the Endpoint Manager?

I’ve been trying to find logs that explain what happened with no luck, every time i attempt to pick an extension from the phone asterisk crashes & restart but the phone does not get registered…

Thanks for any tips, id be glad to share more logs let me know what could help!

NM


Asterisk constantly crashing
#2

Coincidence ?


(Arthur) #3

I don’t believe it is firewall related at all, probably corupted something in the app. Everything works fine when the app is turned off…! I Think i’ll be ok with the endpoint manager from now on.

The crash happens when a phone tries to register for the first time…

Weird though.


#5

sangoma support took a look at my appliance and said they downgraded digium phone module to 18.0_3.6.3 and the crashes stopped.


Asterisk constantly crashing
#6

so not “coincidental” :wink:


#7

nope… But I think we missed each other earlier in the thread. I was agreeing with you that the other post was NOT a coincidence…


#8

(nor was I being sarcastic perhaps prescient though :slight_smile: good that they fixed it ! )


(Arthur) #9

The All Seing Dicko!

Ashcortech, maybe try to switch to the endpoint manager DPMA, i was able to get back and going, support for that plugin is probably going to be better down the line…?


(Dan Corwin) #10

New server, installed all updates. New D80s. Nothing will talk. On the D80s I get a list of the extensions however when I try to configure the phone to the extension it times out.

Downgraded to 3.6.3 as well and my issues went away.

After having 3.6.5-1 installed I ran:
yum downgrade asterisk16-res_digium_phone
This removed 3.6.5-1 and install 3.6.3-2.

I then ran fwconsole restart, configured the D80, and all is OK for now.


#11

yeah this is one of my older systems. All new systems use EPM with DPMA. That was going well until the latest bug in the phone VPN functionality I hit last friday. Support confirmed it’s a bug yesterday and said they opened a dev ticket.