Asterisk constantly crashing


#1

Have a client that switched IT providers and they new company had to reset and rebuild the Sonicwall (puke) firewall because they couldn’t get into it. The FreePBX40 appliance has a reserved IP and that went away. I got called in, set the IP back to it’s old and set it static (outside the DHCP range).

phones connected but had no audio in either direction if we called out or took calls in, internal ext to ext calls were fine. I assume the guys doing the firewall didn’t port forward 10000-20000 correctly. They’re addressing that…

Then I noticed asterisk kept restarting. Seems to restart every minute or so. I see nothing in the logs indicating why. Restarted a phone here and it won’t pull down it’s config because asterisk keeps restarting before it can get the config…

Tried to upgrade asterisk from 16.20 to 17 but that failed…

essentially nothing changed on the FreePBX 15 settings except setting the ip static through admin > system admin

Thoughts??


Digium Phone App Totally Broke
#2

look for crashes in /var/log/messages (or /var/log/syslog)


#3

thanks @dicko,

segfault at 30 ip 00007f55b78531e1 sp 00007f55a8111bd0 error 4 in res_digium_phone.so[7f55b77df000+220000]


#4

If you are not using digium phones then ‘noload’ the module.


#5

Problem is we are using them


#6

Then perhaps switch the asterisk you are using, it should provide a different module


#7

tried upgrading to 17 but that didn’t take. if I use the the asterisk-version-switch tool and basically tell it to reload 16 will think that would help?


#8

:wink: I have no idea, try it. . .


#9

doing it now


#10

Still happenting, about ever 30 seconds

segfault at 30 ip 00007f7b5f9c71e1 sp 00007f7b50091bd0 error 4 in res_digium_phone.so[7f7b5f953000+220000]


#11

unload the digium module - just to see if that fixes it or if some other issue crops up…


#12

Well. if you cant do 17 and 16 is broken, what other options does the version switch offer?


#13

also, was the system recently rebooted/restarted?
last | less
should show if the system restarted


#14

yes why would that matter?


(Lorne Gaetz) #15

I’m not aware of any other reports of this. Try changing to Asterisk 18 and if issue persists open a phone support ticket.


#16

will do that now…


#17

Wondering if the system was restarted/crashed in a way that corrupted the filesystem


#18

no, it was a clean restart


#19

asterisk 18 installed, same issue

Sep 14 17:56:12 newtontm kernel: asterisk[23387]: segfault at 30 ip 00007f30976c5b61 sp 00007f308010abd0 error 4 in res_digium_phone.so[7f3097652000+220000]
Sep 14 17:56:56 newtontm kernel: asterisk[23664]: segfault at 30 ip 00007f3cceea0b61 sp 00007f3cc09adbd0 error 4 in res_digium_phone.so[7f3ccee2d000+220000]
Sep 14 17:57:23 newtontm kernel: asterisk[24043]: segfault at 30 ip 00007fea88788b61 sp 00007fea706babd0 error 4 in res_digium_phone.so[7fea88715000+220000]


#20

btw, if I remove the module, the crashing stops…