Digium FXO setup

configuration
Tags: #<Tag:0x00007fafc8fed808>

(Nice Guy) #1

I’m new to FreePBX, I bought a server and a digium card got it installed(the card). Installed FreePBX but when trying to setup Dahdi it doesnt recognize my card. Help anyone!?

DAHDi Doesn’t appear to be running. Click the ‘Restart DAHDi & Asterisk’ button below

There’s the message I get on the dahdi config page but when i restart I still get the same error.


(Dave Burgess) #2

In the general case, you probably need to go through the manual process for setting DAHDI up. DAHDI is a separate program that operates “more or less” independent of Asterisk, which operates “more or less” independent of FreePBX.

The DAHDI handling in FreePBX has improved by quantum leaps in the past five years, but the advice I usually give people is “set it and forget it”. There’s almost no reason to update or mess with DAHDI once you have it working. When you get to that point, lock it down and don’t try to mess with it.


(Nice Guy) #3

Well thanks for the advice but I can’t seem to get it working.
Do you know how to edit it?


#4

You can start with running dahdi_cfg from the command line and see if it detects the card. If the card is correctly installed on the pci slot and works as expected, the script should detect it, identify it and configure it.


(Nice Guy) #5

[root@freepbx ~]# dahdi_cfg
Notice: Configuration file is /etc/dahdi/system.conf
line 0: Unable to open master device ‘/dev/dahdi/ctl’

1 error(s) detected

I know freepbx detects the card i can see it when i run “Dahdi_hardware”


#6

Probably a botched configuration. You could try renaming /etc/DAHDI/system.conf and re-run dahdi_cfg


(Nice Guy) #7

tried that didn’t work. So I deleted the module and im trying to reinstall but I cant seem to get the right version .

It says “It appears you do not have the right sources for the 3.10.0-957.21.3.e17.x86-64 kernel installed.”

Does anyone have a link to a proper source that I can use?


(Dave Burgess) #8

This is starting to look like a “non-distro” installation. Here in the forum, we always assume you are working from a Distro system.

What platform are you working from, what version of FreePBX are you using and what Asterisk?


(Nice Guy) #9

NAME=“Sangoma Linux”
VERSION=“7 (Core)”
ID=“sangoma”
ID_LIKE=“centos rhel fedora”
VERSION_ID=“7”
PRETTY_NAME=“Sangoma Linux 7 (Core)”
ANSI_COLOR=“0;31”
CPE_NAME=“cpe:/o:sangoma:sng:7::server:utf8”
HOME_URL=“https://distro.sangoma.net/
BUG_REPORT_URL=“https://issues.sangoma.net/

CENTOS_MANTISBT_PROJECT=“Sangoma-7”
CENTOS_MANTISBT_PROJECT_VERSION=“7”
REDHAT_SUPPORT_PRODUCT=“sangoma”
REDHAT_SUPPORT_PRODUCT_VERSION=“7”


(Nice Guy) #10

I see no dahdi module that matches my kernel version on the digium website :confused: someone help


#11

I think you are confusing the DAHDI module for FreePBX with the DAHDI kernel module.


(Nice Guy) #12

I mean I might be i’m completely new at FreePBX.
So is that i’m having a kernel issue?


#13

You are probably not. What is most probable is that your DAHDI configuration is corrupted and you should be able to set it up again from scratch. Or the worst case would be your card is not working. I think the DAHDI configuration issue is most possible.


(Dave Burgess) #14

https://wiki.freepbx.org/display/FPG/DAHDI+Configs would be a good thread to start with…

Even though there is a FreePBX module for DAHDI, DAHDI is still a separate package with its own configuration. You can set it up without FreePBX, an exercise I recommend, even if you are going to eventualy set it up for the module.


(Nice Guy) #15

freePBX detects the card so I don’t think that is the issue. I believe its the config

So how do i set it up from scratch, well I know 1st I have to install the kernel module over but I can’t seem to find one to match the kernel version


#16

In any case, you don’t need the FreePBX module to configure DAHDI. Please post the output of dahdi_cfg -v


(Nice Guy) #17

I’ve been through this thread before it doesn’t help because dahdi fails to start


#18

The kernel module is already installed, otherwise the card would not be detected. You shouldn’t need to mess with the kernel module.


(Nice Guy) #19

okay

[root@freepbx etc]# dahdi_cfg -v
DAHDI Tools Version - 2.11.1
Notice: Configuration file is /etc/dahdi/system.conf
line 0: Unable to open master device ‘/dev/dahdi/ctl’

1 error(s) detected


#20

Also post the output of dahdi_hardware -v