FreePBX | Register | Issues | Wiki | Portal | Support

Digium d62's go to unavailable

digium
Tags: #<Tag:0x00007f749f1fb6c8>

(Nhatton) #1

For some reason we have a branch whose phones are going to unavailable after a few minutes. We sent them new phones and the problem continues to happen.


(Malcolm Davenport) #2

It’s not likely to be anything specific to the phone. It’s more likely that the connection is being interrupted / dropped by something between the branch and the PBX. If the phones are using UDP as a transport, you should look at the udp_ka_interval phone option. It’s set to 0 (off/never) by default. When set to a positive integer value, it’ll send a CRLF SIP packet to the server at the specified value, in seconds, which generally helps to keep NAT devices from closing holes and re-assigning ports.

<setting id="udp_ka_interval" value="60" />

Is probably good for many cases. There’s equipment out there, cough Adtran cough, though that’ll close NAT holes faster than 60 seconds, so you’d want something quicker, e.g. 20 seconds.


(Nhatton) #3

Where do i go in Freepbx to make that change?


(Malcolm Davenport) #4

It depends on what’s configuring the phone? I’m not a good person to ask this question. :smiley:

Let’s pretend it’s Endpoint Manager. Basefile Edit > your Digium template > D62 >

It looks like it sets it to 60 seconds already. Perhaps you’ve something that closes NAT holes faster than 60 seconds. Try a lower value.

That said, this may not be your problem. It’s just a likely culprit. Remote phones are usually behind NAT. NAT routers usually like to keep things tidy, so they close inactive ports periodically. When that happens, the server can’t get to the phone, until the phone decides to reestablish communications with the server. When the phone does come back, it’ll come back on a new port, through the NAT route.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.