Digium Addons ->

Yesterday I posted a message about upgrading the Digium Addons module (on an ubuntu 12.04 LTS server) and it complaining about needing the Digium “php-digium_register-3.0.5-1_centos6.i686.rpm”.
After running the amportal a … it seems to work and the module admin stated that version was installed and enabled.
But when I try to open the “Digium Addons” link in the Admin tab of the menubar, it starts complaining again about needing that rpm file …

Any help would be welcome.


Debian/Ubuntu does not natively support rpm’s (RedhatPackageManager)

I know, I download that rpm directly from digium yesterday and then I used Alien to transform the rpm to a ubuntu/debian deb file, which installed without any problems.
But it still wants that rpm-file.

So any help that would help fix that, so I can actually use the Digium Addons (I need the Fax functionally and the codec wouldn’t hurt either) would be most welcome …


Perhaps you don’t strictly need it’s functionality:-




add your licensing yourself:-


or perhaps

amportal a ma download digiumaddoninstaller
amportal a ma install digiumaddoninstaller

but you will likely get

“This Module Requires The Digium RPM to be installed (php-digium_register-3.0.5-1_centos6.i686.rpm)”

You will have to wait for Shmooze/Digium’s official position as to Debian support for that module though.

Thanks for trying to help:

  • The amportal command I did yesterday and they update the module in de module admin,
    but when trying to access the ‘Digium Addons’ link in the Admin menu, I still get that message.

  • The first 2 links are no help because either I can’t install that RPM or I don’t get the menu to install the licenses and such …

  • The www.tridata.us link simply doesn’t work as far as I can tell …


Sorry I couldn’t help I have for many years used Debian with FreePBX and IWYM but you can no longer use any commercial modules and apparently some Open Source ones that are are constructed specific to RH.

I should mention that I do have a couple of Digium phones, so I know it can work, I will also say that I am not too impressed by them, but that’s a personal opinion and I hope it will change as they develop.

I tried again to get some info the background, but I am no longer allowed to “Private Message” anybody including you or the Community Manager ( The James) go figure . . . :wink:

Gotta love that Fahrenheit 451 :slight_smile:

This is annoying :frowning:

The reason I installed on ubuntu 12.04 LTS is because Centos doesn’t play very nicely with the VIA c3-processor that is on that Mini-ITX board.

Guess I’m screwed either way …

It appears an update to the forum software broke this. It was not our doing.

Stop trying to create unnecessary drama and tension. Not everything is about you or against you.

Will let you know when the problem is resolved.

The plan was to give you a solution on Monday when I’m at my terminal. Since this is the weekend. You gave us less than 23 hours to give you a solution before you starting bring out dystopian society book references

@dicko are your PMs not working? This isn’t aNY sort of official injunction. Our last conversation was in PM.

As far as VIA processors I would throw em in the trash. They are junk regardless of OS. They will cause you greef, kill kittens, etc etc.

I have stress tested a lot of boards, processors etc and via is by far one of the worse things I have ever layer hands on.

It’s a Nehemiah version it shoudl have a full i686 instruction set but it does lack PAE.
For several reasons I’m simply stuck with this architecture at the moment.

But the baseline problem isn’t related to the CPU: I guess I’m not the only person running Asterisk/FreePBX on a non-RH distro?