Dialled number gets 'All circuits busy' message


(M0 Soo) #1

Hi there, I seem to be having an issue dialling my parents (local) telephone number. I last called them on the 15th October and all was ok. Now every time I try and call them, I get a message that says I have dialled an invalid number. I can dial all other numbers ok but not theirs. I have tried calling them from my mobile and it connects ok?
I have checked with their phone provider (TalkTalk) to see if somehow my number has been blocked but it hasn’t. They can call me ok but I cant call them?
Any help you could give me would be much appreciated.
The number I am trying to call is 01723 35xxxx all other numbers usining the same area code and first digit (3) work ok!
I have tried dialling the number both with and without the area codes but it still fails.
Many thanks,
Kind regards
Jason


#2

In the Asterisk log, does a failed call show ... Called PJSIP/(trunkname) ... or … Called SIP/(trunkname) ... ? If not, there is likely a problem with your Outbound Routes or other config. If you can’t find it, post the log here.

If the call was sent to the trunk, at the Asterisk command prompt type
pjsip set logger on
or
sip set debug on
according to trunk type. Make another failing test call. Paste the Asterisk log (which will now include a SIP trace) at pastebin.freepbx.org and post the link here.


(M0 Soo) #3

Hi,

Hopefully this is what you mean! LOL…

https://pastebin.freepbx.org/view/cae34d30


#4

Line 187:
[2020-10-25 18:49:14] VERBOSE[13191][C-0000005b] pbx.c: Executing [s@macro-dialout-trunk:35] NoOp("SIP/200-000000bb", "Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 1") in new stack
shows that sipgate rejected the call, but
sip set debug on
was not active during the call, so we can’t see the details. There was a three second delay before the reject, during which some audio was played. Did you hear a sipgate error message (played before the ‘all circuits are busy now’ message from Asterisk)?

Just guessing here, if your folks are on TalkTalk but the other numbers you can call successfully are on BT or some other carrier, it’s possible that TalkTalk is fussier about e.g. caller ID format or destination number format are are rejecting the call. Sipgate may have documentation about that. You can also look carefully at the INVITE they send on a incoming call and confirm that you are using the same formats on your outgoing calls.

If you still have trouble, paste another log with sip debug on.


(M0 Soo) #5

Hi again,
Yes, there is a message that says ‘You have chosen an invalid number’ played before the Asterisk message. I have since discovered another couple of telephone numbers that I cant call since my original post.
I’m not sure about how to do the sip set debug on thing! I’ll have to look at that tomorrow.
Really appreciate your help!
Regards
Jason