Dial plan for extension

Hi, I am new to all of this so bear with me if I am making obvious or silly questions.

I bought a Sangoma S205 and have provisioned it in the Endpoint manager. I will only be using the FreePBX for internal use, so will only be dialing to extensions.

I have made 3 extensions; 100, 200 and 300. The last two are using softphones. When dialing from the S205 I need to push the # key to make the call go through. How do I force the phone to understand that the number is only 3-digit long? I have fiddled with the dial plan in the Endpoint manager but did not make it work.

Thanks in advance for your help.

I believe you want


Remember per Kari’s law all extensions must be able to dial 911

poke @lgaetz to confirm…


Thanks @jfinstrom and @lgaetz
Prior to posting I looked at the wikipage and also tried xxx but this did not work, hence my post. I realize that I should have made that clear. See my screenshot below. Am I doing anything wrong?

The ? hover button has a lot of information - have you looked at that as well. Once you start with the dial pattern modification, you need to take care of all of the possible combinations to satisfy the phone. Also, there are more than just the pattern - there are other elements of the dial plan that need to be included in there.

Thanks for your help, @cynjut. I did indeed look at the ? but it only says “Enter dial patterns for the phone to use. NOTE: patterns change between manufacturers and not all manufacturers use patterns.” which does not help much. I am just looking for the phone to make the call after the 3-digit extension has been entered. I will not be using the freepbx for any other dialing than internal with 3-digit extensions.

I found out that the S205 was not receiving the config from my server, as the standard setting is to go to rs(dot)sangoma(dot)net. I changed that to the IP of my server and boom, it worked. I now have 3-digit dialing! Thanks to those who tried to help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.