Default installed Modules on FreePBX 15

This list looks really weird. Can anyone at Sangoma explain the reasoning for this?

[[email protected] ~]$ sudo fwconsole ma listonline
No repos specified, using: [standard,commercial] from last GUI settings

+----------------------+------------+---------------------------------------------+-------------+
| Module               | Version    | Status                                      | License     |
+----------------------+------------+---------------------------------------------+-------------+
| accountcodepreserve  | 13.0.2.2   | Enabled and up to date                      | GPLv2       |
| amd                  | 15.0.2     | Enabled and up to date                      | GPLv3+      |
| announcement         | 15.0.3.6   | Online upgrade available (15.0.3.10)        | GPLv3+      |
| api                  | 15.0.3.6   | Online upgrade available (15.0.3.7)         | AGPLv3+     |
| areminder            | 15.0.14.8  | Online upgrade available (15.0.14.18)       | Commercial  |
| arimanager           | 15.0.3.3   | Online upgrade available (15.0.3.8)         | GPLv3+      |
| asterisk-cli         | 14.0.1     | Enabled and up to date                      | GPLv3+      |
| asteriskinfo         | 15.0.4.1   | Online upgrade available (15.0.6)           | GPLv3+      |
| backup               | 15.0.8.61  | Online upgrade available (15.0.8.83)        | GPLv3+      |
| blacklist            | 15.0.2.6   | Online upgrade available (15.0.2.10)        | GPLv3+      |
| broadcast            | 15.0.10    | Online upgrade available (15.0.12)          | Commercial  |
| builtin              |            | Enabled; Not available online               |             |
| bulkhandler          | 13.0.15    | Online upgrade available (13.0.16)          | GPLv3+      |
| calendar             | 15.0.4.6   | Online upgrade available (15.0.4.19)        | GPLv3+      |
| callback             | 15.0.5     | Online upgrade available (15.0.8)           | GPLv3+      |
| callerid             | 15.0.8     | Online upgrade available (15.0.13)          | Commercial  |
| callforward          | 15.0.8     | Online upgrade available (15.0.10)          | AGPLv3+     |
| calllimit            | 15.0.5.1   | Online upgrade available (15.0.5.3)         | Commercial  |
| callrecording        | 15.0.7.8   | Online upgrade available (15.0.7.11)        | AGPLv3+     |
| callwaiting          | 15.0.4.1   | Online upgrade available (15.0.4.2)         | GPLv3+      |
| campon               | 13.0.4.1   | Enabled and up to date                      | GPLv3+      |
| cdr                  | 15.0.11    | Online upgrade available (15.0.15)          | GPLv3+      |
| cel                  | 15.0.11    | Online upgrade available (15.0.15.6)        | GPLv3+      |
| certman              | 15.0.10    | Online upgrade available (15.0.18)          | AGPLv3+     |
| cidlookup            | 15.0.7     | Online upgrade available (15.0.14)          | GPLv3+      |
| conferences          | 15.0.6.5   | Online upgrade available (15.0.7.4)         | GPLv3+      |
| conferencespro       | 15.0.3.9   | Online upgrade available (15.0.3.13)        | Commercial  |
| configedit           | 13.0.7.1   | Enabled and up to date                      | AGPLv3+     |
| contactmanager       | 15.0.8.9   | Online upgrade available (15.0.8.23)        | GPLv3+      |
| core                 | 15.0.9.44  | Online upgrade available (15.0.9.62)        | GPLv3+      |
| cos                  | 15.0.6     | Online upgrade available (15.0.8)           | Commercial  |
| customappsreg        | 15.0.11    | Online upgrade available (15.0.13)          | GPLv3+      |
| cxpanel              | 15.0.2     | Online upgrade available (15.0.3)           | GPLv3       |
| dahdiconfig          | 15.0.5.1   | Online upgrade available (15.0.5.4)         | GPLv3+      |
| dashboard            | 15.0.1.1   | Online upgrade available (15.0.3)           | AGPLv3+     |
| daynight             | 15.0.7     | Online upgrade available (15.0.11)          | GPLv3+      |
| dictate              | 15.0.4     | Online upgrade available (15.0.6)           | GPLv3+      |
| digium_phones        | 15.0.2     | Enabled and up to date                      | GPLv2       |
| digiumaddoninstaller | 13.0.1.1   | Enabled and up to date                      | GPLv2       |
| directory            | 15.0.12    | Online upgrade available (15.0.15)          | GPLv3+      |
| disa                 | 15.0.4.6   | Online upgrade available (15.0.4.7)         | AGPLv3+     |
| donotdisturb         | 15.0.5     | Online upgrade available (15.0.6)           | GPLv3+      |
| endpoint             |            | Not Installed (Locally available)           | Commercial  |
| extensionroutes      | 15.0.4     | Online upgrade available (15.0.5)           | Commercial  |
| extensionsettings    | 13.0.4     | Enabled and up to date                      | GPLv3+      |
| fax                  | 15.0.13    | Online upgrade available (15.0.18)          | GPLv3+      |
| faxpro               | 15.0.7     | Online upgrade available (15.0.8.7)         | Commercial  |
| featurecodeadmin     | 13.0.6.4   | Enabled and up to date                      | GPLv3+      |
| filestore            | 15.0.3.3   | Online upgrade available (15.0.3.7)         | AGPLv3      |
| findmefollow         | 15.0.13    | Online upgrade available (15.0.17)          | GPLv3+      |
| firewall             | 15.0.3     | Online upgrade available (15.0.6.4)         | AGPLv3+     |
| framework            | 15.0.16.20 | Online upgrade available (15.0.16.38)       | GPLv2+      |
| fw_langpacks         | 14.0.1     | Enabled and up to date                      | GPLv3+      |
| hotelwakeup          | 15.0.5.1   | Online upgrade available (15.0.5.4)         | GPLv2       |
| iaxsettings          | 15.0.5     | Online upgrade available (15.0.6)           | AGPLv3      |
| infoservices         | 15.0.2     | Enabled and up to date                      | GPLv2+      |
| iotserver            |            | Not Installed (Available online: 14.0.0.23) | Commercial  |
| irc                  | 13.0.1     | Enabled and up to date                      | GPLv3+      |
| ivr                  | 15.0.14    | Online upgrade available (15.0.23)          | GPLv3+      |
| languages            | 15.0.6     | Online upgrade available (15.0.10)          | GPLv3+      |
| logfiles             | 13.0.10.7  | Enabled and up to date                      | GPLv3+      |
| manager              | 15.0.5     | Online upgrade available (15.0.8)           | GPLv2+      |
| miscapps             | 15.0.4     | Online upgrade available (15.0.8)           | GPLv3+      |
| miscdests            | 15.0.2.5   | Online upgrade available (15.0.2.9)         | GPLv3+      |
| music                | 15.0.11    | Online upgrade available (15.0.20)          | GPLv3+      |
| outroutemsg          | 15.0.7     | Online upgrade available (15.0.9)           | GPLv3+      |
| paging               | 15.0.4.10  | Online upgrade available (15.0.4.17)        | GPLv3+      |
| pagingpro            | 15.0.1.5   | Online upgrade available (15.0.1.9)         | Commercial  |
| parking              | 15.0.9     | Online upgrade available (15.0.14)          | GPLv3+      |
| parkpro              | 15.0.11    | Online upgrade available (15.0.12.5)        | Commercial  |
| pbdirectory          | 2.11.0.6   | Enabled and up to date                      | GPLv3+      |
| phonebook            | 15.0.7     | Online upgrade available (15.0.11)          | GPLv3+      |
| phpinfo              | 13.0.2     | Enabled and up to date                      | GPLv2+      |
| pinsets              |            | Not Installed (Locally available)           | GPLv3+      |
| pinsetspro           |            | Not Installed (Locally available)           | Commercial  |
| pm2                  | 15.0.3.6   | Online upgrade available (15.0.3.7)         | AGPLv3+     |
| pms                  |            | Not Installed (Locally available)           | Commercial  |
| presencestate        | 15.0.5     | Online upgrade available (15.0.8)           | GPLv3+      |
| printextensions      |            | Not Installed (Locally available)           | GPLv3+      |
| queueprio            |            | Not Installed (Locally available)           | GPLv3+      |
| queues               |            | Not Installed (Locally available)           | GPLv2+      |
| queuestats           |            | Not Installed (Locally available)           | Commercial  |
| qxact_reports        |            | Not Installed (Locally available)           | Commercial  |
| recording_report     |            | Not Installed (Locally available)           | Commercial  |
| recordings           | 15.0.3.4   | Online upgrade available (15.0.3.13)        | GPLv3+      |
| restapps             |            | Not Installed (Locally available)           | Commercial  |
| ringgroups           |            | Not Installed (Locally available)           | GPLv3+      |
| sangomacrm           |            | Not Installed (Locally available)           | Commercial  |
| setcid               |            | Not Installed (Locally available)           | GPLv3+      |
| sipsettings          | 15.0.6.7   | Online upgrade available (15.0.6.22)        | AGPLv3+     |
| sipstation           |            | Not Installed (Locally available)           | Commercial  |
| sms                  | 15.0.3     | Online upgrade available (15.0.4)           | Commercial  |
| soundlang            | 15.0.4.1   | Online upgrade available (15.0.5.6)         | GPLv3+      |
| speeddial            | 2.11.0.4   | Enabled and up to date                      | GPLv3+      |
| superfecta           |            | Not Installed (Locally available)           | GPLv2+      |
| sysadmin             | 15.0.13.4  | Online upgrade available (15.0.13.11)       | Commercial  |
| timeconditions       | 15.0.12    | Online upgrade available (15.0.14)          | GPLv3+      |
| tts                  |            | Not Installed (Locally available)           | GPLv3+      |
| ttsengines           | 15.0.4.3   | Online upgrade available (15.0.4.6)         | AGPLv3      |
| ucp                  | 15.0.6.3   | Online upgrade available (15.0.6.13)        | AGPLv3+     |
| userman              | 15.0.8.2   | Online upgrade available (15.0.22)          | AGPLv3+     |
| vega                 |            | Not Installed (Locally available)           | Commercial+ |
| vmblast              |            | Not Installed (Locally available)           | GPLv3+      |
| vmnotify             |            | Not Installed (Locally available)           | Commercial  |
| voicemail            | 15.0.17.5  | Online upgrade available (15.0.18.11)       | GPLv3+      |
| voicemail_report     |            | Not Installed (Locally available)           | Commercial  |
| vqplus               |            | Not Installed (Locally available)           | Commercial  |
| weakpasswords        |            | Not Installed (Locally available)           | GPLv3+      |
| webcallback          |            | Not Installed (Locally available)           | Commercial  |
| webrtc               |            | Not Installed (Locally available)           | GPLv3+      |
| xmpp                 | 15.0.6.2   | Online upgrade available (15.0.6.4)         | AGPLv3      |
| zulu                 | 15.0.57.7  | Online upgrade available (15.0.57.12)       | Commercial  |
+----------------------+------------+---------------------------------------------+-------------+

Specifically, Ring Groups and Queues are not enabled by default? Seriously?
Then on the security concious side, Weak Passwords is not enabled?

Edit: Here is the GPL list not installed.

[[email protected] ~]$ sudo fwconsole ma listonline | grep Not | grep GPL
| pinsets              |            | Not Installed (Locally available)           | GPLv3+      |
| printextensions      |            | Not Installed (Locally available)           | GPLv3+      |
| queueprio            |            | Not Installed (Locally available)           | GPLv3+      |
| queues               |            | Not Installed (Locally available)           | GPLv2+      |
| ringgroups           |            | Not Installed (Locally available)           | GPLv3+      |
| setcid               |            | Not Installed (Locally available)           | GPLv3+      |
| superfecta           |            | Not Installed (Locally available)           | GPLv2+      |
| tts                  |            | Not Installed (Locally available)           | GPLv3+      |
| vmblast              |            | Not Installed (Locally available)           | GPLv3+      |
| weakpasswords        |            | Not Installed (Locally available)           | GPLv3+      |
| webrtc               |            | Not Installed (Locally available)           | GPLv3+      |

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.