Dashboard takes one minute to load

Hmmm… I’d start looking at the httpd configuration next. Something you could try is dropping a static HTM file into your /var/www/html/ folder, and see if it is also slow to load. If it is, that would indicate an issue with your http server or configuration. If it loads instantly, it’s more likely something with your database, php, and so forth.

Hi Greg,

Thanks again for your response. It only happens when loading dashboard, other parts on the GUI work very fluid. It’s just only the dashboard that takes really long time to load… If it’s a database or php problem would happen on the whole GUI, isn’t it?

Thank you!

Do your have any pending updates not installed?


I Have all the modules up to date.

Thank you

Do you have any news? I have the same problem with dashboard.


Remove rss feeds in advanced settings


Ooooh… didn’t think about that. Good catch!

I see the same issue where the dashboard takes what looks like exactly one minute to load. With rss feeds enabled the loading progress bar sits at 85% for one minute, if I remove rss feeds the progress bar sits at 75% for one minute.

I suspect the issue is with the system overview widget. If I refresh any other widget it refreshes immediately, but if I refresh the system overview widget it takes one minute to refresh.

I’m using System Dashboard

Your issue is different than other issues here.

Thanks for the reply. It’s my first post on this forum, should I create a new thread? I’m not sure how to get some troubleshooting help with my issue.

Hi to all!

Waw! Thank you for your responses! I have to say that I tried what you suggested Andrew, and happens me the same as evijafar, If I remove rss feeds progress bars stuck for a minute on 75%. If I re-add rss feeds, the progress bar comes back to stuck on 85%.

Thank you!!!

This begs the question “What is happening AFTER the RSS Feed Widget loads?” It’s the same thing that happens after the system overview widget if you remove the RSS Feed widget, so the problem is after the RSS Feed Widget. How would we find out what happens next?

I’d have to see what the system overview looks like to be able to do anything

I’ve had trouble with dashboards loading slowly and every time what fixed it for me was setting the system’s first DNS server to In my case, DNS resolution (for I’m not sure what) was timing out before the dashboard loaded. Make your public (or local) DNS servers your 2nd and 3rd entries.

Hope that helps.

1 Like

I’d have to see what the system overview looks like to be able to do anything

Sure thing. A screenshot? Remote session?

I did have same problem. When i login the dashboard. Dashboard loading is going to %85 and then waiting a few minutes. It is very annoying problem. I checked dashboards modules. The problem was system overview module. Finally I did resolve this.
Firstly I am connected server via ssh. Then, i did write “mailq” command. And this command result of a few minutes. My problem is postfix settings. I did check my server host name with “hostname” command. My host name is not qualyfied. Hostname is invalid. It hasnt got dns records. I removed invalid hostname from “/etc/sysconfig/network”, “/etc/sysconfig”, “hostname”. I restarted with “/etc/init.d/network restart” command. Then, I did write “mailq” command. This command result did come of instantly. Finally, I did refresh dashboard. And Problem is fixed…


EUREKA!!! Thank you so much devsoftazilim.

I checked what you said me but seems to be correct all. But you give me the clue to solve the problem. After checking my hostname y saw that was correct, what I had to do is edit “/etc/host” file and leave it like this: localhost hostnameofmymachine
::1 localhost hostnameofmymachine
Reload network settings and that’s it!


1 Like

Looks like freepbx does a dns lookup for the name of the host it is running on when you click “Dashboard”. I found the host it was looking for by running ‘tcpdump port 53’. I then added the host name to /etc/hosts using ip

It loads without delay now.

It actually does a sendmail right when dashboard loads. If it’s slow for you then it’s because your sendmail is misconfigured. Now is that a bug in FreePBX? Yes. But if you want it fixed now fix your sendmail.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.