FreePBX | Register | Issues | Wiki | Portal | Support

Dashboard takes one minute to load


(Guillem) #1

Hi!

I’m having problems with dashboard since I installed FreePBX 14. It stucks on 85% loading and takes 1 minute to load.
Checking with Firebug I saw that /admin/ajax.php?command=getcontent&module=dashboard&rawname=Overview&section=overview takes 1 minute and 1 sec to reply.
Is there anything that I can do? On another freepbx 13 that I have it loads really quick

Thanks in advance!


(Greg) #2

Time for some troubleshooting.

Run “top” on your FreePBX box and monitor it while the dashboard loads. See if anything is using too much CPU.

Try running the dashboard on another machine, see if the problem is common to the server, or to the workstation.

Try clearing your cache / temporary internet files (Sometimes your computer takes more time looking through the cache than it would have just fetching the file again)

Try a different browser (chrome, IE, edge)


(Guillem) #3

Hi Greg!

Thank you for your response. I checked top and nothing seems to be consuming high CPU. As well I checked on different computers, OS and browsers and happens the same.

Only afects on dashboard loading, the system works perfectly working around the GUI, applying changes and other stuff.

Thank you!


(Guillem) #4

any suggestions?


(Guillem) #5

any help?


(Greg) #6

Hmmm… I’d start looking at the httpd configuration next. Something you could try is dropping a static HTM file into your /var/www/html/ folder, and see if it is also slow to load. If it is, that would indicate an issue with your http server or configuration. If it loads instantly, it’s more likely something with your database, php, and so forth.


(Guillem) #7

Hi Greg,

Thanks again for your response. It only happens when loading dashboard, other parts on the GUI work very fluid. It’s just only the dashboard that takes really long time to load… If it’s a database or php problem would happen on the whole GUI, isn’t it?

Thank you!


(Itzik) #8

Do your have any pending updates not installed?


(Guillem) #9

Hi!

I Have all the modules up to date.

Thank you


(Lojsdf Pojksfd) #11

Do you have any news? I have the same problem with dashboard.

Thanks.


(Andrew Nagy) #12

Remove rss feeds in advanced settings


(Greg) #13

Ooooh… didn’t think about that. Good catch!


(eviljafar) #14

I see the same issue where the dashboard takes what looks like exactly one minute to load. With rss feeds enabled the loading progress bar sits at 85% for one minute, if I remove rss feeds the progress bar sits at 75% for one minute.

I suspect the issue is with the system overview widget. If I refresh any other widget it refreshes immediately, but if I refresh the system overview widget it takes one minute to refresh.

I’m using System Dashboard 14.0.4.1


(Andrew Nagy) #15

Your issue is different than other issues here.


(eviljafar) #16

Thanks for the reply. It’s my first post on this forum, should I create a new thread? I’m not sure how to get some troubleshooting help with my issue.


(Guillem) #17

Hi to all!

Waw! Thank you for your responses! I have to say that I tried what you suggested Andrew, and happens me the same as evijafar, If I remove rss feeds progress bars stuck for a minute on 75%. If I re-add rss feeds, the progress bar comes back to stuck on 85%.

Thank you!!!


(Dave Burgess) #18

This begs the question “What is happening AFTER the RSS Feed Widget loads?” It’s the same thing that happens after the system overview widget if you remove the RSS Feed widget, so the problem is after the RSS Feed Widget. How would we find out what happens next?


(Andrew Nagy) #19

I’d have to see what the system overview looks like to be able to do anything


(Caretech) #20

I’ve had trouble with dashboards loading slowly and every time what fixed it for me was setting the system’s first DNS server to 127.0.0.1. In my case, DNS resolution (for I’m not sure what) was timing out before the dashboard loaded. Make your public (or local) DNS servers your 2nd and 3rd entries.

Hope that helps.


(eviljafar) #21

I’d have to see what the system overview looks like to be able to do anything

Sure thing. A screenshot? Remote session?