DAHDI Analog Ports Missing - Digum 800d A8B

During an upgrade from 11 to 14 in January 2018 the dahdi board, a Digum 800d A8B, ceased working. I found a post about a driver issue, kmod-wanpipe and wanpipe, so I did what was suggested and rolled the driver back to 7.0.20-9.sng7. This solved the problem and has been working fine.

At some point this past Friday the dadhi board quit working again. I was not notified until today. I have applied all upgrades, from the GUI and also o/s upgrades. The dadhi board still reports no ports. I ran several downgrades which did not help. The last downgrade I tried was from which should have taken it down to 7.0.20-9.sng7 but that failed stating “Only Upgrade available on package: Kmode-wanpipe-7.0.21-1.sng7.x86_64” and the same for wanpipe.

How can I downgrade to or better yet, why can’t I run the latest version of wanpipe an have the board work?

When I run dahdi_hardware it returns the following:

pci:0000:09:00.0 wcaxx- di61:800d Digium A8B

No answers or suggestions?

Currently running:

Current PBX Version:
Current System Version: 12.7.5-1805-2.sng7

When I run dahdi_hardware it returns the following:

pci:0000:09:00.0 wcaxx- di61:800d Digium A8B

dahdi_cfg -vv
DAHDI Tools Version - 2.11.1

DAHDI Version: 2.11.1
Echo Canceller(s):

Channel map:

0 channels to configure.

I have them currently using SipStation until we can get the Digium board working again.

I have had them order a clone board which I have had NO issues in other installations but it will not be in until Monday.

confused, Are you using sangoma card or digium card? FreePBX supports both of them. if you use digium card, you not not need to care about wanppipe which is a driver for sangoma card. if you have FXSs on the board, you have to plugin the cable for 12V power supply.

Thanks for the reply. I believe your questions to me are stated in my first post on this thread, so Instead of me repeating, please read the first post.

This is installed 8.5 hours from my location so I cannot open the server and physically look at the board.

When I run dahdi_hardware it returns the following:
pci:0000:09:00.0 wcaxx- di61:800d Digium A8B

So according to what dahdi_hardware AND my documentation from when I built and installed this system in 2014, it is a 800d Digium A8B board, specifically a 1A8A03F board, which has 8 FXO ports, 0 FXS ports.

I am not sure that, but i also faced that problem before from china, freepbx take much time to install. it might be DNS problem or slow internet.

Regarding the card setting, have you tried to config that from freepbx GUI? go to dahdi config… follow this link:

It is not slow Internet or a DNS problem. It is simply a driver issue with the newer release. I fixed this exact problem in January 2018 when I upgraded to 14. I had to roll the driver back to an earlier version and the problem went away until this past Friday. Others had the same problem with their upgrades between October 17 and January 18. I am unable to roll back the driver to the one I need.

The system is working 100% now that I have changed them to Sip Station, but they want to get the hardwired lines working. They have a new FXO board on order and it will be in Monday. Once they install it I believe it will resume working. The board that is in there is NOT bad, just the driver does not work.

Yes, I looked at the link you provided. However, you can’t configure a the channels from the GUI if the DAHDI does not see the channels…

you have to config dahdi card first.

Thank you for attempting to help, but what I believe you do not understand, is this WAS a WORKING System and has been since 2014. Everything was working fine until a the drivers were updated.

You do not need anything wanpipe , that is only needed for Sangoma hardware.

Thanks Dicko,

I did not purposely install wanpipe, apparently it was installed. The odd part is in January 2018 when I upgraded the working system from v11 to v14 the digium board quit working. I found a post from another person that he had the same problem and downgraded to a previous version. I downgraded and the board started working. This past Friday the board quit working. I attempted to downgrade but it will not go far enough back.

Maybe I am confused and I do not have wanpipe installed. What are the procedures to get the board working again?

Personally i would download the version of dadhi that worked for you from Digium


Then follow the ages old manual method


then you should disable /uninstall /delete all the freepbx dahdi helpers stuff or you will have your work overwritten.

You would be responsible for building groups as needed and arranging channels, but what you had before should still work.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.