Custom UCP-URL in outgoing emails and translations

Hey there!

I’m using FreePBX’ UCP behind a reverse proxy, which does neat things like TLS, IDS/IPS and stuff.
So far so good, problem being the URLs sent by FreePBX in outgoing mails to users.
Internally, UCP is being accessed by http://freepbx.[domain].dom:81, however - from the outside world it’s https://ucp.[domain].com. FreePBX, of course, doesn’t know about that and sends mails containing the local dns name to users.
In the User Management -> Settings-Tab, I’ve configured the Hostname to be https://ucp.[domain].com, however in the mail it’s being sent as http://ucp.[domain].com:81 - which obviously leads to absolutly nothing.

How do I change that so mails contain the correct URL?

Also, little sidequestion: Mail translations are missing some important stuff. Is there a way to add custom translations to strings like “Password Reset Link (Valid Until: […]”?

is your reverse proxy proxying tcp:81 correctly ? You can re-write ip and ports as much as you want. What exactly is your 'reverse proxy?

Nope, that’s the whole point.
UCP is accessible from outside on https://ucp.[domain].com. Port 443, tcp. The reverse proxy proxies this internally to the PBX:

At no point is the PBX aware of the fqdn and port and that’s the problem. Where do I configure the correct domains inside Freepbx, so it get’s used for emails?

Let’s back up a couple of steps, exactly how are you ‘reverse proxying’ anything?

That does not not matter. He has a working reverse proxy on his public IP, routing to http://ip:81. Enough said.

@Quafi Sounds like the voicemail notification? That is setup here:

1 Like

Hey @sorvani, thank you! But unfortunately I’m not talking about Voicemail notifications (sorry for not clarifying that enough), but rather mails sent by the user management module - like those sent to new users or password reset mails.
For the first one, you can change the template a bit under User Management -> Settings. However, even if the hostname there is specified correctly as https, Freepbx changes it to
Same goes for password reset mails (for which I couldn’t find any place to modify the templates).

Since translations are sometimes missing aswell, I’ve dug a bit through the config files (specifically / userman.po found in /var/www/html/admin/modules/userman/i18n/de_DE/LC_MESSAGES/), but even if you add certain translations to the userman.po, they aren’t respected by the system. Probably because they’re not configured in the

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.