CronManager Error

This is the second time in 3 days that I received this error:

The following commands failed with the listed error
/var/lib/asterisk/bin/module_admin listonline > /dev/null 2>&1 (255)

I deleted it the 1st time since I read that it may have been an intermittent connection error but now that it happened again I figured I would ask here. Is there something I should do for this error?

Have you checked online in the gui recently or run the command yourself to let us know what the error is

I check the GUI just about everyday and it always works and seems fine. In fact even today I checked the Admin Module and ran the XMPP update with no problems at all. I then checked the System Admin Updates function and it says the system is up top date with no obvious errors. I not sure how to run the command myself through CLI but I am going to clear the error in the system status and see if it comes back again.

The command is thus:

/var/lib/asterisk/bin/module_admin listonline

Sorry for the delayed response.

I ran the command and it ran with no errors and showed a complete match for what I see on the GUI. After clearing the error last time it hasn’t come back and right now the GUI and the CLI show everything is up to date and seemingly fine.

Just got this error again after updating:
broadcast 2.11.8 (current: 2.11.7.1)
restapps 12.0.24 (current: 12.0.22)
userman 12.0.25 (current: 12.0.24)

Ran the CLI command /var/lib/asterisk/bin/module_admin listonline and got the following:

[[email protected] ~]# /var/lib/asterisk/bin/module_admin listonline
no repos specified, using: [commercial,standard,extended] from last GUI settings

PHP Fatal error: Uncaught exception ‘Exception’ with message ‘Unable to start GPG’ in /var/www/html/admin/libraries/BMO/GPG.class.php:353
Stack trace:
#0 /var/www/html/admin/libraries/BMO/GPG.class.php(456): GPG->runGPG(’–keyserver poo…’)
#1 /var/www/html/admin/libraries/modulefunctions.class.php(2848): GPG->refreshKeys()
#2 /var/lib/asterisk/bin/module_admin(573): module_functions->getAllSignatures(false)
#3 /var/lib/asterisk/bin/module_admin(860): showList(true)
#4 {main}
thrown in /var/www/html/admin/libraries/BMO/GPG.class.php on line 353

Hmmm getting this again on one of my servers… its always the same server that gives me this error at times.

The following commands failed with the listed error
/var/lib/asterisk/bin/module_admin listonline > /dev/null 2>&1 (255)

Why don’t you run the command manually like I said previously and see what it says to you

I actually did Andrew and it came back fine again, which it seems to always do. Do you think its just a brief connection error to the list? Just seems odd to me that this is the only box that it ever happens on but once again I deleted the error and it hasn’t returned yet.

Yes thats all I think it is.

OK Thanks we will keep an eye on it and were changing this PBX to a new install at another network location so it will be interesting to see what happens

I keep getting the same error when applying the configuration. I tested on command line and received the same error:

# /var/lib/asterisk/bin/module_admin listonline
no repos specified, using: [standard,extended,commercial] from last GUI settings

PHP Fatal error:  Uncaught exception 'Exception' with message 'Unable to start GPG' in /var/www/html/admin/libraries/BMO/GPG.class.php:353
Stack trace:
#0 /var/www/html/admin/libraries/BMO/GPG.class.php(456): GPG->runGPG('--keyserver poo...')
#1 /var/www/html/admin/libraries/modulefunctions.class.php(2863): GPG->refreshKeys()
#2 /var/lib/asterisk/bin/module_admin(570): module_functions->getAllSignatures(false)
#3 /var/lib/asterisk/bin/module_admin(857): showList(true)
#4 {main}
  thrown in /var/www/html/admin/libraries/BMO/GPG.class.php on line 353

any clues?

You need to install GPG.

I have the same error in my web console, but when running this command in terminal - the only error I get is:

Unable to open /dev/dahdi/ctl: No such file or directory

I also see this error a lot when upgrading… it does not seem to effect the phone system from functioning properly.

I’m having the same error shown in my Dashboard. Using FreePBX 13.0.195.18

I checked that GPG is installed as you can see in the commands and output below. Any idea/help?

[root ~]# yum install gpg
Loaded plugins: fastestmirror, kmod
Setting up Install Process
Loading mirror speeds from cached hostfile
base | 2.0 kB 00:00
extras | 1.3 kB 00:00
pbx | 2.9 kB 00:00
schmooze-commercial | 2.9 kB 00:00
updates | 1.3 kB 00:00
Package gnupg2-2.0.14-8.el6.x86_64 already installed and latest version
Nothing to do

[root ~]# /var/lib/asterisk/bin/module_admin listonline
no repos specified, using: [commercial,standard,extended] from last GUI settings

Whoops\Exception\ErrorException: Comments starting with ‘#’ are deprecated in Unknown on line 23 in file /var/www/html/admin/libraries/BMO/GPG.class.php on line 613
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/BMO/GPG.class.php:613
  2. Whoops\Run->handleError() :0
  3. parse_ini_string() /var/www/html/admin/libraries/BMO/GPG.class.php:613
  4. FreePBX\GPG->checkSig() /var/www/html/admin/libraries/BMO/GPG.class.php:174
  5. FreePBX\GPG->verifyModule() /var/www/html/admin/libraries/modulefunctions.class.php:3266
  6. module_functions->updateSignature() /var/www/html/admin/libraries/modulefunctions.class.php:3172
  7. module_functions->getAllSignatures() /var/lib/asterisk/bin/module_admin:571
  8. showList() /var/lib/asterisk/bin/module_admin:862

Getting exactly the same error on FreePBX 14.0.4.5:

[[email protected] ~]# /var/lib/asterisk/bin/module_admin listonline
no repos specified, using: [standard,commercial] from last GUI settings

Whoops\Exception\ErrorException: Comments starting with '#' are deprecated in Unknown on line 23 in file /var/www/html/admin/libraries/BMO/GPG.class.php on line 624
Stack trace:
  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/BMO/GPG.class.php:624
  2. parse_ini_string() /var/www/html/admin/libraries/BMO/GPG.class.php:624
  3. FreePBX\GPG->checkSig() /var/www/html/admin/libraries/BMO/GPG.class.php:174
  4. FreePBX\GPG->verifyModule() /var/www/html/admin/libraries/modulefunctions.class.php:3263
  5. module_functions->updateSignature() /var/www/html/admin/libraries/modulefunctions.class.php:3169
  6. module_functions->getAllSignatures() /var/lib/asterisk/bin/module_admin:567
  7. showList() /var/lib/asterisk/bin/module_admin:858
[[email protected] ~]#

Running fwconsole ma listonline gives a similar result:

[[email protected] ~]# fwconsole ma listonline
No repos specified, using: [standard,commercial] from last GUI settings


In GPG.class.php line 624:

  Comments starting with '#' are deprecated in Unknown on line 23


ma [-f|--force] [-d|--debug] [--edge] [--stable] [--color] [--skipchown] [-e|--autoenable] [--skipdisabled] [--snapshot SNAPSHOT] [--format FORMAT] [-R|--repo REPO] [-t|--tag TAG] [--onlystdout] [--willupdate] [--securityonly] [--sendemails] [--] [<args>]...

[[email protected] ~]#
cd /var/www/html/admin/modules
find -name "module.sig" | xargs grep -i '^#'

@nmartine @chaser Post the results.

2 Likes

It’s not the same error at all @PitzKey provided a command that will help you fix it

No results from the 2 commands:

[root ~]# cd /var/www/html/admin/modules
[root modules]# find -name “module.sig” | xargs grep -i ‘^#’
[root modules]#

The error is because you have a module.sig in your modules folder with a # symbol as a starting line. We haven’t supported that since version 12. You’ll need to manually find a file like that and fix it.