"Core" (In-call) Feature Codes in Asterisk 13

I switched to Asterisk 13 to try out a new feature. When I tried to switch back, I realised that the recent upgrade of “asterisk-version-switch” no longer contains the option to select Asterisk 11. So I guess I’m stuck on 13.

Now my In-call feature codes are all messed up with a single # initiating a call transfer.
I prevented the * from hanging up by following instructions to add “disconnect=*#” to "features_featuremap_custom.conf but none of the settings in Freepbx GUI: Feature Codes “-Core” category are saving.

There are many IVRs that require following a series of digits with the # key.
I’d appreciate very much if someone could shed some light on what is happening and what can be done to manually save custom codes.

This has nothing to do with Asterisk version. I have just tested, and in-call feature codes are all working as expected in the GUI:

34693894*CLI> features show
Builtin Feature           Default Current
---------------           ------- -------
Pickup                    *8      *8
Blind Transfer            #       **55
Attended Transfer                 **44
One Touch Monitor                 **77
Disconnect Call           *       **66

You can upgrade with:

fwconsole ma --edge upgrade framework
fwconsole ma --edge upgrade core

edit - change fwconsole commands to reflect versions that were later published.

This works on any version of FreePBX? (thought that the first octet represents the version of FreePBX)

What is your current FreePBX version? When you stated you were prevented from changing to Asterisk 11, I assumed you are on 14.

1 Like

Thank you for your response. I am on Freepbx 14. I’m going to upgrade to the edge version now and see how it goes.
Thank you.

Currently when I run “features show” after making changes in the GUI it doesn’t indicate any changes.


Submit the page again, and re-apply config. If there is still an issue, provide the versions of core and framework you are running.

It’s working now. It seems editing the custom file prevented the settings being saved.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.